Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#10179 closed Bug (invalid)

Bug on image dialog behavior

Reported by: Jose Carlos Aparicio Owned by:
Priority: Normal Milestone:
Component: Core : Parser Version: 4.0.1
Keywords: Cc:

Description

It was found a bug on image dialog behaviour. When i try to set a new image, for instance:

http://img593.imageshack.us/img593/7804/cap1yg.png

Ckeditor translate it to html successfuly

<img alt="" src="http://designals.net/wp-content/uploads/2011/10/tarjetas-04.jpg" style="width: 600px; height: 430px;" />

But when i submit it, HTML code which is send is wrong

<img alt="" src="http://designals.net/wp-content/uploads/2011/10/tarjetas-04.jpg"  600px; height: 430px;" />

So, style tag "style="width:" is deleted. I think CKeditor corrupt html code when content is posted.

Change History (3)

comment:1 Changed 7 years ago by Jose Carlos Aparicio

Keywords: style width img added; removed

comment:2 Changed 7 years ago by Jakub Ś

Keywords: image dialog behaviour bug tag delete deleted style width img removed
Resolution: invalid
Status: newclosed
  1. CKEditor has nothing to do with data submit.
  2. Whether CKEditor breaks code can be checked with AJAX sample (e.g. http://nightly.ckeditor.com/13-03-08-08-51/full/samples/ajax.html) which acts as submit but doesn't use one. It writes content to the page when editor is destroyed and loads them when it is created. If image doesn't break there you should rather debug whole request and look for the problem in your application. This can be caused by regex filters in your app or perhaps wrong encoding or field type used in DB (some DBs don't handle multiline text correctly or line breaks they receive from web (the second one might be caused by different encodings used))

I'm closing this issue as invalid. if you are able however to reproduce this problem in AJAX sample or any other way without using submit please describe how can this be done and I will reopen this issue.

comment:3 Changed 7 years ago by Piotrek Koszuliński

BTW. You can update your CKEditor to 4.0.2. We fixed that image dialog layout issue, which is caused by a bug in Chrome (see #10123).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy