Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#10189 closed Bug (wontfix)

IE7 - 'dropdown' toolbar items not working

Reported by: lukeb Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IE7 Cc:

Description

In IE7 toolbar items that create a 'dropdown' menu to select from (such as font, size and text color) do not appear to work. When the icon is clicked nothing happens. This behaviour can be reproduced in versions:

  • 4.0.1
  • 4.0.2
  • 4.1rc
  • Nightly at 2013-03-11

In the 4.0 release however the 'dropdown' toolbar items do work.

I've tried to reduce this to a simple test case which is attached.This expects the ckeditor files to be present in the 'scripts/ckeditor' subdirectory

Attachments (1)

10189-ie7dropdownbug.zip (1.7 KB) - added by lukeb 7 years ago.

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by lukeb

Attachment: 10189-ie7dropdownbug.zip added

comment:1 Changed 7 years ago by Piotrek Koszuliński

Keywords: IE7 added
Resolution: wontfix
Status: newclosed

This is because you placed textarea directly in the form element. For some weird reason IE7 does not like that. Place this textarea inside e.g. paragraph and everything will be ok.

We could try to fix this issue, but it's very unlikely that we'll do this because there is a trivial workaround and... this is IE7. So I'm closing this ticket.

comment:2 Changed 7 years ago by lukeb

Thanks for the quick response, I would never have guessed that moving the textarea outside of the form would resolve this. Wish I was in a position where I could ignore IE7!

comment:3 Changed 7 years ago by Piotrek Koszuliński

Hehe :) We all are waiting for that day.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy