Opened 7 years ago

Closed 7 years ago

#10196 closed Bug (fixed)

Context menus not displaying with keyboard shortcuts when autogrow is enabled

Reported by: Teresa Monahan Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.0.3
Component: General Version: 4.0
Keywords: IBM Cc: Damian, Satya Minnekanti, irinauru, fabrizio

Description

To Reproduce:

  • Open plugins/autogrow/samples/autogrow.html in a browser.
  • Insert some content which is wide enough to introduce a horizontal scroll bar e.g. a table with a width of 1500px.
  • Use the keyboard shortcut to open the context menu: Ctrl+Shift+F10

Problem: The context menu does not display. Occasionally it displays very briefly and then disappears again.

This is reproducible since commit 7c5782a where the following code was added to plugins/floatpanel/plugin.js:

editor.on( 'resize', function() {
           this.hide();
	}, this );

In v3 and v4, the resize event gets fired when the keyboard shortcut keys are pressed. Therefore when the code above was added in v4, this forces the floatpanel to be hidden. Do you know why this code was added to the floatpanel plugin? Can it be safely reverted?

Attachments (1)

10196.html (784 bytes) - added by Olek Nowodziński 7 years ago.
Sample to reproduce the issue

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by Piotrek Koszuliński

Status: newconfirmed
Version: 4.0.24.0

The git:7c5782a was the patch for #9465 (fixed in 4.0). It seems to be ok to revert it in order to temporarily fix this issue.

This issue is reproducible from 4.0.

comment:2 in reply to:  1 Changed 7 years ago by Teresa Monahan

Can this ticket please be targeted for the 4.0.3 milestone? This is an accessibility issue which is a very high priority for us. It makes it impossible for keyboard-only users to use context menus in the given scenario.

comment:3 Changed 7 years ago by Olek Nowodziński

Milestone: CKEditor 4.0.3
Owner: set to Olek Nowodziński
Status: confirmedassigned

Changed 7 years ago by Olek Nowodziński

Attachment: 10196.html added

Sample to reproduce the issue

comment:4 Changed 7 years ago by Olek Nowodziński

Status: assignedreview

Created branch t/10196 with a fix. The problem was the horizontal scrollbar's height being considered when retrieving the height of the view pane.

comment:5 Changed 7 years ago by Piotrek Koszuliński

Status: reviewreview_failed

Patch seems to fix the issue on FF and Chrome and IE8 which I so far tested.

However, I found an issue which it unfortunately introduces. On FF:

  1. Open autogrow sample.
  2. Write few paragraphs in 2nd editor (with max height) so vertical scroll appears.
  3. Scroll to the bottom (it doesn't have to be the end, but it's more probable to reproduce this issue there).
  4. Try to place caret somewhere in the text by clicking.
  5. Content is scrolled to the top.

comment:6 Changed 7 years ago by Piotrek Koszuliński

PS. In fact I'm afraid that this patch may introduce more similar issues, because setting overflow-x to hidden may for example cause automatic scroll to the left.

Can't we fix this issue by blocking incorrect resize event? Don't we know when it should be really fired.

comment:7 Changed 7 years ago by Piotrek Koszuliński

Owner: changed from Olek Nowodziński to Piotrek Koszuliński
Status: review_failedreview

I pushed t/10196b with different fix. It prevents calling editor.resize() when the height hasn't changed (like when opening context menu).

comment:8 Changed 7 years ago by Olek Nowodziński

Status: reviewreview_passed

comment:9 Changed 7 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Fixed on master with git:18a9148.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy