Opened 7 years ago

Closed 6 years ago

#10240 closed Bug (duplicate)

[IE] JS errors logged when pressing delete in specific case

Reported by: Piotrek Koszuliński Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0
Keywords: IE8 Cc:

Description

  1. Open replacebyclass sample.
  2. Focus editor and place cursor at the beginning of first header.
  3. Press delete few times.
  4. If you've been lucky IE logged from one to tens of JS errors.

I can reproduce this issue on IE8, but I haven't checked other IEs. Sometimes I have to repeat this TC few times.

Error:

  Invalid argument.  node.js, line 295 character 3

Sometimes different one is logged:

  Invalid argument.  selection.js, line 928 character 10

I've been able to reproduce this issue from 4.0, but I think that it is older, because I stopped being able to reproduce it when we changed our sample content layout (image was moved from left to right).

Change History (2)

comment:1 Changed 7 years ago by Jakub Ś

Keywords: IE8 added
Status: newconfirmed
Version: 4.0 Beta4.0

I was able to reproduce this problem in IE8 only from CKEditor 4.0.

I have tried to use similar content in 4.0 beta (image aliment to right) but no error occurred.

comment:2 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

This is in fact DUP of #10584

@Reinmar I'm closing your issue as duplicate of #10584 as the former explains better what is going on.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy