Opened 7 years ago

Closed 7 years ago

#10278 closed Bug (invalid)

CKEditor 4 conflicts with PureText add-on

Reported by: Danny Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 4.0.1
Keywords: Cc:

Description

When pasting text using the PureText add-on for Windows (http://www.stevemiller.net/puretext/), all text in the editor becomes unformatted.

Reproduce:

  1. Make sure you have some formatted (bold/italics/underlined) text inside ckeditor;
  2. Select any text (may be inside or outside the editor);
  3. Copy the text (either with a button or CTRL+C);
  4. Paste the text INSIDE the editor using PureText (usually using the default shortcut Windows key + V)

All text inside the editor has now magically turned into unformatted text. All the text that was bold (or italics etc.) is now plain text.

By the way: this bug was NOT in CKEditor 3.

Change History (2)

comment:1 Changed 7 years ago by Jakub Ś

Keywords: paste format formatting puretext removed
Status: newpending

I have tried this TC in various browsers and nowhere such change happened.

  1. Could you tell me in which browser you are getting this?
  2. Does it happen in latest CKEditor 4.1, demo version or nightly http://nightly.ckeditor.com/
  3. Which version of editor you are using? It is standard, basic, full or perhaps created

with builder? Could you send us your build-config.js file?

  1. Perhaps text has to be pasted into particular element in editor. Where do you paste your text exactly (What is the code in editor and into which element do you paste)?

comment:2 Changed 7 years ago by Piotrek Koszuliński

Resolution: invalid
Status: pendingclosed

I also cannot reproduce this issue. Also, we won't work on making CKEditor compatible with this kind of application if this is not an editor issue.

Note: you don't need to use puretext if you have Allowed Content Filter correctly configured. Read more here: http://ckeditor.com/blog/CKEditor-4.1-Released

I'm closing this issue, since it's very unlikely that this is a bug in editor. However, we can always reopen it if I'm wrong. We just need more information to be able to reproduce it.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy