Opened 6 years ago

Closed 6 years ago

#10304 closed Bug (fixed)

Standard and basic config.js presets should contain all toolbar groups

Reported by: Piotrek Koszuliński Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0
Keywords: Cc:

Description

Based on: http://ckeditor.com/forums/CKEditor/Bidi-is-not-working-with-Version-4.1

Problem: bidi toolbar group is missing in standard preset, so adding bidi plugin does not result in bidi buttons appearing in toolbar.

This is against toolbar groups concept which we introduced to avoid this issue. Therefore in all presets all standard groups should be defined and if preset removes some buttons it should do this by removeButtons (e.g. paste buttons in basic preset should not be removed from toolbarGroups, but like superscript, subscript and strike).

Change History (3)

comment:1 Changed 6 years ago by Wiktor Walc

The buttons are removed by commenting out a particular toolbar group because it is a cleaner way than removing additional 6 buttons.

However, if a 3rd party plugin defines its button in this group, then the user that added this plugin to basic preset might be lost. So I tend to agree that using removeButtons would be a safer approach.

comment:2 Changed 6 years ago by Piotrek Koszuliński

Status: newconfirmed

comment:3 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

Fixed on release/4.1.x, major and master.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy