Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10307 closed New Feature (wontfix)

Ability to specify where to append the toolbar's menus element

Reported by: Hadrien Lanneau Owned by:
Priority: Normal Milestone:
Component: UI : Toolbar Version: 4.1.1
Keywords: menu, toolbar, overlay, iframe Cc:

Description

More details here : http://ckeditor.com/forums/CKEditor/Menu-as-iframe#comment-124806

The need is to have a configuration setting to tell where the menu element container have to be appened. I want to append it at body's root.

Change History (3)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: newclosed

This is very specific requirement. We cannot expose this option as an configuration option - no one except you would ever use it (ok... maybe few guys ;).

We could modify these lines somehow to allow forcing using parentElement argument instead of editor element, but you would have to fork CKEditor and change format, style, font and color dropdowns so they will use this new option. Especially that changing this behaviour causes an issue with floating toolbar, because dropdown menus are no longer positioned according to toolbar, but to entire document, so they desynchronize.

Therefore IMO the best solution is you forking CKEditor with small patch removing these two lines or introducing config option for them. Since CKEditor is open source project and uses Github this won't be a lot of work and is the right solution in this situation.

Last edited 6 years ago by Piotrek Koszuliński (previous) (diff)

comment:2 Changed 6 years ago by Hadrien Lanneau

I understand your arguments. BUT ! The problem is that the behavior is different when you instanciate a classic editor with iframe, the menu will be appended in body, but with an inline editor, the menu will be in the container element. This is inconsistant and you should at least fix that to have the menu appended in body in each cases.

comment:3 Changed 6 years ago by Piotrek Koszuliński

Inconsistent? No - it is consistent. We always choose the best solution for the problem we're solving. This is consistency. Moving panels to body when we have floating toolbar would complicate things very much because when toolbar is changing position we would have to update panels positions too. I don't see any reason to make things harder.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy