Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#10308 closed Bug (fixed)

Unspecified Error when deleting a Row in Internet Explorer 10

Reported by: Rick Schnorenberg Owned by: Marek Lewandowski
Priority: Normal Milestone: CKEditor 4.2.2
Component: Core : Tables Version: 3.6.6
Keywords: IE10 Cc:

Description

Description

Deleting rows other than the first one lead to an Unspecified Error and cause the UI to be unresponsive for a few seconds.

Steps to Reproduce

  1. Launch the Nightly Editor Demo in IE10 (I tested against http://nightly.ckeditor.com/13-04-08-14-51/standard/samples/replacebyclass.html)
  2. Insert a table using the default options of the dialog
  3. Right click on the second or third row and choose Delete Rows
  4. An Unspecified Error will be logged in the Developer Tools console and the UI will become unresponsive for a few seconds

System

Browser: Internet Explorer 10 (Desktop Mode)
OS: Windows 8 Enterprise

Attachments (1)

table.html (4.5 KB) - added by Jakub Ś 6 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 7 years ago by Jakub Ś

Keywords: IE10 added
Status: newconfirmed
Version: 3.6.6 (SVN - trunk)

Problem can be reproduced in both CKE 4.x (v4) and CKE 3.x. It is reproducible from CKEditor 3.6.6.

Right-clicking on table was possible from rev. [7661]. In that revision this TC has caused "SCRIPT606: Could not complete the operation due to error 800a025e."

Error mentioned in that ticket can be reproduced from rev. [7662].

comment:2 Changed 6 years ago by Jakub Ś

Simplified code sample helping to reproduce the problem.

<p><a id="tech-details" name="tech-details"></a></p>

<table border="1" bordercolor="#ccc" cellpadding="5" cellspacing="0" style="border-collapse:collapse; margin:10px 0px 10px 15px">
	<tbody>
		<tr>
			<td>Commander</td>
			<td>Neil A. Armstrong</td>
		</tr>
		<tr>
			<td>Command Module Pilot</td>
			<td>Michael Collins</td>
		</tr>
		<tr>
			<td>Lunar Module Pilot</td>
			<td>Edwin &quot;Buzz&quot; E. Aldrin, Jr.</td>
		</tr>
	</tbody>
</table>

Changed 6 years ago by Jakub Ś

Attachment: table.html added

comment:3 Changed 6 years ago by Jakub Ś

Another TC:

  1. Download attached table.html and copy its HTML into editor.
  2. Go to table containing EUR e.g second row, second column.
  3. Right-click and select Delete Rows.

You get unspecified error and editor will only start responding when you click on editor document scrollbar.

comment:4 Changed 6 years ago by Wiktor Walc

Milestone: CKEditor 4.2.2

comment:5 Changed 6 years ago by Jakub Ś

Very similar issue was reported in #10894. I would say it is a duplicate that extends this ticket.

comment:6 Changed 6 years ago by Marek Lewandowski

Owner: set to Marek Lewandowski
Status: confirmedassigned

comment:7 Changed 6 years ago by Marek Lewandowski

Interesting note: it seems to only occur if you don't have a range selected. So if you are moving caret with keyboard etc.

comment:8 Changed 6 years ago by Marek Lewandowski

Status: assignedreview

This exception also occured when we attempted to ie.

  • remove cell in last ceil of middle row
  • remove column

These cases were also included into our test case.

Solution pushed to branch t/10308 at dev and tests.

comment:9 Changed 6 years ago by Frederico Caldeira Knabben

Lemme give some background to the proposed fix.

It looks like, in this specific case involving tables, the DOM changes executed by our code are making IE crazy. The selection API for the editable document gets totally broken. By broken I mean: IE start throwing weird errors for anything you try to do with selection without any clear reason.

There is no logic on these errors as we're doing everything right. So the only solution we found for this is "resetting" the selection API, by moving the focus to another document (CKEDITOR.document) and then back to the editable. Fortunately this solved the problem, even if its a damn ugly hack.

comment:10 Changed 6 years ago by Olek Nowodziński

Status: reviewreview_passed

Created branch t/10308b with the essence of what is in t/10308 and does the job.

I also simplified tests by removing obsolete styles, text and stuff, pushed to t/10308@tests-v4.

comment:11 Changed 6 years ago by Marek Lewandowski

Resolution: fixed
Status: review_passedclosed

Fixed with git:01b1e52d99a3a (dev) and ae68661b17 (tests) in master.

Last edited 6 years ago by Olek Nowodziński (previous) (diff)

comment:12 Changed 6 years ago by Olek Nowodziński

Moved further discussion to #10960.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy