Opened 6 years ago

Closed 5 years ago

#10960 closed Bug (wontfix)

[IE10+] Error thrown and broken range produced while creating bookmarks

Reported by: Olek Nowodziński Owned by:
Priority: Normal Milestone:
Component: Core : Selection Version: 4.2.2
Keywords: Cc:

Description (last modified by Olek Nowodziński)

This ticket refers to the dirty fix we "developed" for #10308.


The problem re-appeared while testing 4.2.2 in dt/plugins/tabletools/tabletools.html (full-all) because of undo manager creating snapshots.

Those lines in tabletools are not an actual fix because they don't touch the root of the problem, but rather some aspect we merely identified.

Even though the solution is sufficient for 4.2.2, we got to:

  • Check whether IE11 is also affected.
  • Find the real source of that problem.
  • Provide a real fix.

Change History (6)

comment:1 Changed 6 years ago by Piotrek Koszuliński

cc

comment:2 Changed 6 years ago by Olek Nowodziński

Description: modified (diff)

comment:3 Changed 6 years ago by Piotr Jasiun

Owner: set to Piotr Jasiun
Status: newassigned

To check how it works in IE11.

comment:4 Changed 6 years ago by Piotr Jasiun

Deleting tables rows in IE11 works fine on major and full all build, but there is bigger problem with table: #10992.

Last edited 6 years ago by Piotr Jasiun (previous) (diff)

comment:5 Changed 6 years ago by Piotr Jasiun

Milestone: CKEditor 4.3
Owner: Piotr Jasiun deleted
Status: assignedconfirmed

comment:6 Changed 5 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: confirmedclosed

In #10308 we had to target patch introduced in #10308 to IE10 only. So neither we need to check if IE11 needs it (it doesn't) nor there's a sense in trying to find an answer what's the root of this issue, because it happens only on IE10.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy