Opened 6 years ago

Closed 6 years ago

#10313 closed Bug (duplicate)

Hitting Backspace key in Internet Explorer with control selected causes backward navigation

Reported by: Rick Schnorenberg Owned by:
Priority: Normal Milestone:
Component: Core : Editable Version: 4.0
Keywords: IE Cc: jean-francois.fournier@…

Description

Description

Selecting a Control and hitting the backspace key causes backward navigation instead of removing the control from the document, this was fixed in the past for CKEDITOR 3.x 4047 but was reintroduced to 4.x at some point, getSelectedTableList() is not returning an element for IE because the range.startPath() only contains the document body when a table or image is selected.

Steps to Reproduce

  1. Launch the Nightly Editor Demo in IE (I tested against ​http://nightly.ckeditor.com/13-04-09-14-51/standard/samples/replacebyclass.html)
  2. Click on the Saturn V rocket image, or the Red Flag image, or the border of the Mission Crew table
  3. Press the backspace key

Expected Behavior

Control is removed from the document

Actual Behavior

IE navigates to the previous page

System

I was able to reproduce this on IE 7,8,9 and 10.

Change History (3)

comment:1 Changed 6 years ago by Jakub Ś

Status: newconfirmed
Version: 4.14.0

Damn, we had this issue fixed in CKE 3.x and it was working fine in CKEditor 4.0 beta but it got broken again in CKE 4.0.

comment:2 Changed 6 years ago by Jeff Fournier

Cc: jean-francois.fournier@… added

Adding myself to cc.

comment:3 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

This is in fact a duplicate of #10055.

Guys i have moved your cc to that ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy