Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10318 closed Bug (invalid)

ipad can not insert text after changing the cursor point in the ckeditor

Reported by: Anoop Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: iOS Cc:

Description

I am working on a site which uses ckeditor. I am facing an issue using ckeditor in ipad. I am replacing a text area with ckeditor instance.One can enter details in the ckeditor and it works fine. However, if she/he puts the cursor in the middle of a sentence to modify the text and then try to type using the iPad keyboard she/he can press the letters but nothing gets typed in. But now if she/he hides the keyboard and brings it back it works fine. Delete , return keys works well in this scenario.

I have tried the demo provided through ipad. But there is no such issue. Here we are replacing a text area with ckeditor instance.

Thanks, Anoop

Change History (6)

comment:1 Changed 6 years ago by Anna Tomanek

Keywords: iOS added
Status: newpending

Is this the same issue as described in #9937?

Which CKEditor version is that? Does the same thing happen in the samples from the "samples" folder of your CKEditor installation?

If you cannot reproduce it on our demo, try upgrading to the latest CKEditor first to see if it solves the issue.

comment:2 Changed 6 years ago by Anoop

We are using version 4. We tried with the sample where it is working. Will upgrade to 4.1 and check. I think some other js file is causing this issue. We are working on it and will update.

Thank you Anna for your help and reply.

Thanks,

Anoop

Last edited 6 years ago by Anoop (previous) (diff)

comment:3 Changed 6 years ago by Anoop

Hi,

We found out the issue. We were using file called script.js which was used to make the site responsive specially in ipad/iphone. Now we have removed it is working fine without any issues.

Once again thanks for your cooperation and support.

Thanks,

Anoop A

comment:4 Changed 6 years ago by Anoop

This is just to help anyone having this issue. The code that was present in script.js is given below.

$(function(){ IPad/IPhone

var viewportmeta = document.querySelector && document.querySelector('meta[name="viewport"]'), ua = navigator.userAgent,

gestureStart = function () {viewportmeta.content = "width=device-width, minimum-scale=0.25, maximum-scale=1.6";},

scaleFix = function () {

if (viewportmeta && /iPhone|iPad/.test(ua) && !/Opera Mini/.test(ua)) {

viewportmeta.content = "width=device-width, minimum-scale=1.0, maximum-scale=1.0"; document.addEventListener("gesturestart", gestureStart, false);

}

};

scaleFix(); Menu Android var userag = navigator.userAgent.toLowerCase(); var isAndroid = userag.indexOf("android") > -1; if(isAndroid) {

$('.menu').responsiveMenu({autoArrows:true});

}

});

Thanks,

Anoop

comment:5 Changed 6 years ago by Anna Tomanek

Resolution: invalid
Status: pendingclosed

Thank you for your feedback, glad to see that you managed to solve this issue. If you notice any further problems with iPad, please be so kind as to report them here with the "iOS" keyword, it will be much appreciated!

comment:6 Changed 6 years ago by Anoop

Yeah for sure.

Thanks,

Anoop

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy