Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#10333 closed Bug (duplicate)

Paste not working for content with leading or trailing whitespace

Reported by: Teresa Monahan Owned by:
Priority: Normal Milestone:
Component: General Version: 4.1
Keywords: IBM Cc: Damian, Satya Minnekanti

Description

Problem: An error occurs and the content is not pasted.

The error is:

TypeError: wrapper.getLast(...) is null
.../ckeditor/core/editable.js
Line 1146

Change History (3)

comment:1 Changed 7 years ago by Piotrek Koszuliński

Resolution: duplicate
Status: newclosed

Most likely DUP of #10260, which we closed yesterday, so this issue should be already fixed on master. Although, I'm not able to reproduce your TC (manual pasting), so please verify if I'm right.

comment:2 Changed 7 years ago by Jakub Ś

I have checked this in latest nightly (http://nightly.ckeditor.com/13-04-17-07-42/full/samples/replacebyclass.html) and wasn't able to reproduce this as well.

I have tried copying text from various palaces, paste it with Ctrl+V or dialog and past it in various places but no error occurred. Please provide exact steps to reproduce. Please specify browser, what to copy, how to copy, where to paste and how to paste (ctrl+V or dialog).

comment:3 in reply to:  2 Changed 7 years ago by Teresa Monahan

Replying to j.swiderski:

I have checked this in latest nightly (http://nightly.ckeditor.com/13-04-17-07-42/full/samples/replacebyclass.html) and wasn't able to reproduce this as well.

Thanks for investigating this. I can no longer reproduce on nightly or master so it looks like a recent fix addressed this. The issue had been reproducible in FF and IE, not in Chrome. The usecase was to select any word from the editor contents plus some whitespace character e.g. "spaceflight " and copy it using Ctrl+C. Then place the cursor anywhere in the editor and paste using Ctrl+V.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy