Opened 7 years ago

Closed 7 years ago

#10342 closed Bug (duplicate)

CKEditor is automatically add " char around the URL when using background image in IE9

Reported by: Roy Shoa Owned by:
Priority: Normal Milestone:
Component: General Version: 4.1
Keywords: Cc:

Description

Hi, I am having a problem using CKEditor Source and IE9,IE10 that I am pretty sure that its a bug. The CKEditor is automatically add " char around the URL when using background image on a style attribute (in case that I add a apostrophe it replacing it also to ").

e.g. if i add the next code:

<div style="background-image:url('http://b.cksource.com/a/1/10th/ckeditor10years.png');">Test</div>

It will replace to this code: <div style="background-image: url(&quot;http://b.cksource.com/a/1/10th/ckeditor10years.png&quot;);">Test</div>

I understand that its not a bug until now because it is correct but the problem start when I like to send the form, get the data and save the page. When I am getting the posted data in the server side the &quot; char is replaced to “ and then I have a invalid HTML like this:

<div style="background-image: url("http://b.cksource.com/a/1/10th/ckeditor10years.png");">Test</div>

Now, Lets say that we save the data in the database as they are. In the next time that I like to edit the page, when I am applying the CKEditor on the textarea its replacing the code to this code (because of the invalid HTML):

<div 1="" 10th="" a="" b.cksource.com="" style="background-image: none;">Test</div>

If this is not a bug, I was happy if someone can explain to me how I need to work for saving the data correctly?

Change History (1)

comment:1 Changed 7 years ago by Jakub Ś

Keywords: IE9 &quot background image removed
Resolution: duplicate
Status: newclosed

DUP of #7352.

@royshoa your ticket has helped me to clean up a little bit. It seems to me that in case you have described browser makes some changes first and we rely on what browser has given us. As I have pointed out in #7352 - perhaps editor should introduce something like template behaviour which will always create " outside attribute value and ' inside (or similar).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy