Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#10343 closed Bug (fixed)

Chrome & opera - trailing white space lost on paste

Reported by: Teresa Monahan Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0 Beta
Keywords: IBM Chrome Opera Cc: Satya Minnekanti, irinauru

Description

To Reproduce:

  • Open any 4.x sample and type some text e.g. "Sample text".
  • Select the word sample and the whitespace after it i.e. "Sample ".
  • Use Ctrl+C to copy the contents.
  • Place the cursor on a new line and paste the contents using Ctrl+V.

Problem: The space after the word sample is not pasted.

This is reproducible in Chrome and Opera. In Opera, it looks like the space is present initially but if you type directly after the pasted content, the space is removed.

In 3.x, leading and trailing whitespaces were trimmed from all pasted content in all browsers as a result of changeset [6818]. However this is no longer the case with the new pasting mechanism in 4.x. The testcase above correctly preserves the whitespace in IE, FF and Safari.

Change History (5)

comment:1 Changed 7 years ago by Jakub Ś

Keywords: Chrome Opera added
Status: newconfirmed
Version: 4.14.0 Beta

I have checked this issue in Chrome and contenteditable element. It seems we have a bug in editor.

In Chrome when you type "test ", Chrome sees it as "test&bbsp;". If you type "text test" Chrome sees it as "text test". I was thinking that this is source of the problem but it isn't.

Copying "text " from "text test" results in "text " in plain content editable element while in editor it results in "text".

Problem can be reproduced in Opera and Chrome from CKEditor 4.0 beta. In 3.x branch editor trimmed all spaces.

comment:2 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

I cannot reproduce this any more on master:

  1. type 'test test',
  2. select and copy 'test ',
  3. paste it in the middle of word.

White space is correctly preserved.

comment:3 in reply to:  2 Changed 6 years ago by Satya Minnekanti

Replying to Reinmar:

I cannot reproduce this any more on master:

  1. type 'test test',
  2. select and copy 'test ',
  3. paste it in the middle of word.

White space is correctly preserved.

@reinmar I could still reproduce the issue in Opera when i tested on nightly build. It looks like the space is present initially but if you type directly after the pasted content, the space is removed. Please re-open this ticket

comment:4 Changed 6 years ago by Piotrek Koszuliński

Opera recently changed their engine to Blink (the engine used in Chrome), so it's in fact a Chrome's twin brother. I've just checked this TC on Opera Next (it has been already released on Windows few months ago, but AFAIK not for Linux and MacOS still) and this issue is not reproducible.

And now I wanted to write that this issue is still reproducible on old Opera (<15), but... it isn't. The trailing white space is preserved. So perhaps we're trying to reproduce this issue differently.

So:

  • Which Opera do you test?
  • Could you describe exact steps to reproduce this issue?

Please note, that since Opera changed engine, and we are supporting only latest version of it (which is based on Blink), it's rather unlikely that we'll fix issue in the Opera 12.20 which was a completely different browser.

comment:5 in reply to:  4 Changed 6 years ago by Satya Minnekanti

Replying to Reinmar:

Opera recently changed their engine to Blink (the engine used in Chrome), so it's in fact a Chrome's twin brother. I've just checked this TC on Opera Next (it has been already released on Windows few months ago, but AFAIK not for Linux and MacOS still) and this issue is not reproducible.

And now I wanted to write that this issue is still reproducible on old Opera (<15), but... it isn't. The trailing white space is preserved. So perhaps we're trying to reproduce this issue differently.

So:

  • Which Opera do you test?
  • Could you describe exact steps to reproduce this issue?

Please note, that since Opera changed engine, and we are supporting only latest version of it (which is based on Blink), it's rather unlikely that we'll fix issue in the Opera 12.20 which was a completely different browser.

@reinmar i've installed a new version of Opera which is 16 & i can't reproduce the issue on it. Previously i had 12.16 & new version of opera did not come up as an automatic update, that's why i diddn't got it. Any way the issue is not reproducible in chrome & latest opera. so we can close it

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy