Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#10405 closed Bug (invalid)

CKEditor backgroundcolor selection bug

Reported by: Mandeep Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0.2
Keywords: Cc:

Description

Select any text and apply background color.

In Chrome, text is shown as selected. But in FF, there is no selection shown and hence it looks like that the color was not applied at all(unless u click and see).

Also, after clicking and seeing what background color has been applied, try selecting and the text again and the text with the background color, the selection color is absent and it looks dirty.

I am using CKEditor inline version 4.0.2, but i was able to reproduce it on your full featured edtior on the demo site. I am using Firefox version 20.0.1.

Steps to reproduce(FF):

  1. Select some random words and apply background color to them(see attachment _1)
  2. It seems that it did not work. Click inside and you will see what background color has been applied.
  3. Select the complete sentence again(see attachment _2)
  4. You will notice why it looks dirty

Hope I made myself clear

Attachments (2)

CKEditor_background-color_1.png (308.1 KB) - added by Mandeep 7 years ago.
CKEditor_background-color_2.png (412.5 KB) - added by Mandeep 7 years ago.

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by Mandeep

Changed 7 years ago by Mandeep

comment:1 Changed 7 years ago by Piotrek Koszuliński

Resolution: invalid
Status: newclosed

This is a normal Firefox behaviour. When you select a text which is highlighted with dark background colours it does not render this like Chrome - by applying semi-transparent rectangle under which highlight colours are visible. Firefox does it differently - it inverts colours - background becomes white and font colour is changed. This is a bit worse solution than Chrome's, but we cannot do anything about this and it's definitely not caused by CKEditor.

comment:2 Changed 7 years ago by Mandeep

Didnt knew that, sorry. Thanks for the information

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy