Opened 6 years ago

Closed 6 years ago

#10408 closed Bug (invalid)

bbcode plugin: incorrect output for quote tag

Reported by: charvaka Owned by:
Priority: Normal Milestone:
Component: Core : Output Data Version: 4.1.1
Keywords: Cc:

Description

Hello,

I am using CKEditor with a forum that uses BBCode. The plugin works great for the most part, but it produces incorrect output for quotes.

When the plugin is given a quote tag like this:

[quote="user"]
text
[/quote]

it displays the content of the quote as:

"user"
text

When I view source by clicking the source button, it shows:

[quote] "user"
text
[/quote]

All replies saved on my forum go to the database with this incorrect quote format. Please help.

Thanks!

Change History (4)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Status: newpending
  • Input: [quote="user"]text[/quote]
  • Produces this inside editor: <blockquote><cite>user</cite><div>text</div></blockquote>
  • Output (after switching to source mode): [quote="user"]text[/quote]

All that is correct. There's other issue with <br>s being added on each switch to source and back, back quote worked for me ok. On which browser do you have this issue? And what are other requirements to reproduce it?

comment:2 Changed 6 years ago by Piotrek Koszuliński

Keywords: bbcode quote removed

comment:3 in reply to:  1 Changed 6 years ago by charvaka

Replying to Reinmar:

  • Input: [quote="user"]text[/quote]
  • Produces this inside editor: <blockquote><cite>user</cite><div>text</div></blockquote>
  • Output (after switching to source mode): [quote="user"]text[/quote]

All that is correct. There's other issue with <br>s being added on each switch to source and back, back quote worked for me ok. On which browser do you have this issue? And what are other requirements to reproduce it?

Thanks for your response. I checked it again, and it turns out that I was using an incorrect version of the plugin. When I downloaded the latest bbcode plugin and used it, it works fine. Thanks for all your help and sorry for my mistake.

comment:4 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy