Opened 6 years ago

Closed 6 years ago

#10429 closed Bug (invalid)

Spawning  

Reported by: Daniel Gruber Owned by:
Priority: Normal Milestone:
Component: Core : Tables Version: 4.1
Keywords: Cc:

Description

Sometimes   appears in tables or some combinations of spans and strongs with one nbsp within. You can't delete this without removing it in the source code.

Change History (5)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Status: newpending
  1. On which browser?
  2. Inline or framed editor?
  3. Under what circumstances? How can we reproduce this?
  4. Default or custom configuration?

comment:2 Changed 6 years ago by Daniel Gruber

  1. Seems to Take Place in every Browser, but we prefer to use Chrome

Is Seems to apear when pasting from word, doesn't matter if we paste from word or not

  1. Framed
  2. Pasting in tables, see http://mbg-germering.de/aktuelles/speiseplan2/ it's that table, mostly happening when pasting the price of 4€
  3. Custom config, but just disabled new filter options and customized the toolbar a little bit

Our config: https://github.com/danielgruber/Goma-CMS/blob/Dev-Nightly/system/libs/thirdparty/ckeditor4_1/config.js

comment:3 Changed 6 years ago by Jakub Ś

Could you perhaps send us file with code generated by editor after pasting table?

  1. Yes you might get <p>&nbsp;</p> or <td>&nbsp;</td> we use it to fill empty Blocks. You might also get spans with &nbsp;. If there isn't anything in inline element it gets removed. For block elements (using HTML4 naming) you can set fillEmptyBlocks to false. We don't recommend it however and think it should be set to true to help render blocks properly - http://docs.ckeditor.com/#!/api/CKEDITOR.config-cfg-fillEmptyBlocks. This is how editor works there is no error here.
  1. I have noticed something like below code. Then I have checked it in browser without editor logic and result was the same. If browser is passing this to editor there is nothing we can do here.
    <p><strong>Mittwoch; 15.05.2013</strong>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</p>
    
  2. I have noticed that some priced are alligned to left and some are not but this is because some prices had <p align="right"></p>. This attribute is not supported in HTML5 and was deprecated in HTML4 - http://www.w3schools.com/tags/tag_p.asp (text-align:right should be used instead)

Please tell us if you had any of the above in mind. and lease don't forget to send us code generated by editor.

comment:4 Changed 6 years ago by Daniel Gruber

  1. i'll try it
  2. okay, but seems to come from word or anything
  3. how to configure editor to automatically remove this HTML4 code or get HTML5-code?

seems like somebody having the same issues http://ckeditor.com/forums/CKEditor/Cant-Remove-Paragraph-Inside-of-Table-Cell-Swollen-Cell

Thanks a lot!!

Last edited 6 years ago by Daniel Gruber (previous) (diff)

comment:5 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed
  1. I recommend leaving it as it is. IMHO there is nothing wrong in <p>&nbsp;<p> whne comparing it to <p><p>
  2. I don't understand your comment but this is a won't fix issue. Editor gets such data so it won't know this is something you don't want. It can only try fixing code if it isn't in accordance with spec.
  3. There is no such option :) You simply need to get familiar with HTML and use valid HTML syntax for code you want to paste in editor or better any code you use on any page. This isn't only editor that may act funny when you use weird syntax. Browsers try fixing HTML (even in more places that editor) but can also produce weird results when HTML is invalid. Some users tend to say then "browser doesn't work as expected" or "is buggy" without realizing this is their fault.

This isn't the same issue. Forum post concerns extra P added to table cell while you talk about &nbps;

Taking all the above into account I think this issue is invalid and there is no error – only proper editor behaviour.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy