Opened 6 years ago

Closed 5 years ago

#10430 closed Bug (fixed)

Unresolved dependence of image plugin if forms plugin

Reported by: Karen Ananiev Owned by: Piotr Jasiun
Priority: Normal Milestone: CKEditor 4.3
Component: General Version: 4.0
Keywords: Cc:

Description

forms plugin uses "lang.image.titleButton", there is js error if image plugin is removed.

Change History (13)

comment:1 Changed 6 years ago by Jakub Ś

Status: newpending
Version: 4.1.1

I have tried using below code:

var editor = CKEDITOR.replace( 'editor1', {
	removePlugins : 'image'
} );

Next I have tried using form plugin and image button plugin but no error was logged.

@karena what is the proper way to reproduce this and what have I missed?

comment:2 Changed 6 years ago by Karen Ananiev

I've used the source code (dev version) from github and removed image plugin from plugins list.

If you use removePlugins and use release version with included image plugin I guess you'll unable to reproduce.

comment:3 Changed 6 years ago by Jakub Ś

Status: pendingconfirmed
Version: 4.0

Confirmed.
To reproduce go to builder, select full version and remove image plugin from list. Next download release, put it on server and try to open replacebycode sample in browser.

Error will be thrown and editor won't show up.

comment:4 Changed 6 years ago by Jakub Ś

#10242 was marked as duplicate.

comment:5 Changed 6 years ago by Jakub Ś

#9877 was marked as duplicate.

comment:6 Changed 6 years ago by Frederico Caldeira Knabben

Keywords: Discussion added

We have two simple option to follow here:

  1. Mark image plugin dependency on forms.
  2. Do not enable the image button if the image plugin is not available (I mean, not even register the command, button, etc.)

I would go for "2", assuming that image button is not the most important feature provided by the forms plugin. Still we would need this documented somewhere (maybe in the repository itself), to help people understanding this dependency trick.

comment:7 Changed 5 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 4.3

comment:8 Changed 5 years ago by Olek Nowodziński

Note: Once this issue is resolved, image2 sample must be updated.

comment:9 Changed 5 years ago by Piotr Jasiun

Owner: set to Piotr Jasiun
Status: confirmedassigned

comment:10 Changed 5 years ago by Piotr Jasiun

Status: assignedreview

Fixed in t/10430.

comment:11 Changed 5 years ago by Piotr Jasiun

If image plugin is not available then imagebutton will not be shown.

comment:12 Changed 5 years ago by Frederico Caldeira Knabben

Keywords: Discussion removed
Status: reviewreview_passed

comment:13 Changed 5 years ago by Piotr Jasiun

Resolution: fixed
Status: review_passedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy