Opened 6 years ago

Closed 6 years ago

#10450 closed Bug (fixed)

IE10 QM problem

Reported by: somaye Owned by:
Priority: Normal Milestone:
Component: General Version: 4.1
Keywords: IE10 Cc:

Description

Hi , I use ckeditor 4.1.1 and in IE10 QM toolbar's icons looks like disable and some of them makes error like copy and paste

Attachments (2)

CKE10.png (4.6 KB) - added by somaye 6 years ago.
ie10quirks.html (6.6 KB) - added by Jakub Ś 6 years ago.

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by somaye

Attachment: CKE10.png added

comment:1 Changed 6 years ago by Jakub Ś

Keywords: IE10 added
Version: 4.1.14.1

Problem can be reproduced in CKE 4.1 in IE10 quirks mode only (IE5 quirks works fine).

Please used attached sample which contains proper settings that will cause IE10 QM.

Changed 6 years ago by Jakub Ś

Attachment: ie10quirks.html added

comment:2 Changed 6 years ago by Jakub Ś

Status: newconfirmed

comment:3 Changed 6 years ago by imc_ruf

You can reproduce this bug even with the latest ckeditor version 4.1.2. Just get one of the sample files (e.g. samples/replacebycode.html) and remove the first line, containing the doctype definition. Then open the file in IE10.

The problem here is, that IE10 introduced a second Quirks mode similar to other browser’s Quirks mode, while keeping the old Quirks mode as IE5 Quirks mode. There seems to be no way to discriminate one Quirks mode against the other in Javascript. So it’s only possible to make ckeditor working with one of the Quirks modes. Currently only the old IE5 Quirks mode is working.

To make ckeditor work in IE10 Quirks mode, open ckeditor.js, search for the first “a.ie9Compat” and replace it with “a.quirks=a.quirks&&e<10;a.ie9Compat”. Note that this change should not be used in IE5 Quirks mode.

However, the best way would be to use Standards mode by defining <!DOCTYPE html> whenever possible.

comment:4 Changed 6 years ago by Frederico Caldeira Knabben

May be related to #9654, so let's review this once that one gets closed.

comment:5 Changed 6 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

This issue no longer occurs in latest CKEditor 4.2.1.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy