Opened 6 years ago

Closed 6 years ago

#9654 closed Bug (fixed)

CKE 4.x - Problems with IE10 Quirks mode

Reported by: Jakub Ś Owned by: Piotr Jasiun
Priority: Normal Milestone: CKEditor 4.2.1
Component: General Version: 4.0
Keywords: IE10 Cc:

Description

  1. Open attached sample in IE10 (You need to copy it to samples folder)
  2. Switch to source and back

Results:

  • Notice that buttons still have greyed out style (like in source mode)
  • When you click on toolbar button -dialog shows up but JS error is also thrown.

Message: Unable to get property '0' of undefined
Line: 1108
URI: /ckeditor4/plugins/dialog/plugin.js

Attachments (1)

test_quirks.html (313 bytes) - added by Jakub Ś 6 years ago.

Download all attachments as: .zip

Change History (14)

Changed 6 years ago by Jakub Ś

Attachment: test_quirks.html added

comment:1 Changed 6 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 6 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.0.1

comment:3 Changed 6 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.0.1

Situation looks bad. It turns out that IE10 has two Quirks Mode - the new one, which is close to standards and which in fact replaced the old one, because IE10 turns it on when there's no Doctype. And old QM (IE5 mode) which needs meta tag to be turned on.

More info:

Thanks to this brilliant decision editor tries to work in IE5 mode on browser that is in neither IE5 nor standards mode. I haven't checked that, but I guess that we'd need to handle completely new bugs set and we're definitely not going to try to do this now.

comment:4 Changed 6 years ago by Piotrek Koszuliński

Quick test proved that I wasn't right that situation looks so bad :). New IE10's QM is pretty close to std mode, so we just need to modify env.js, so editor's QM isn't turned on on IE10's QM.

comment:5 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 4.2.1

comment:6 Changed 6 years ago by Frederico Caldeira Knabben

#10450 is to be reviewed when closing this one.

comment:7 Changed 6 years ago by Piotr Jasiun

Owner: set to Piotr Jasiun
Status: confirmedassigned

comment:8 Changed 6 years ago by Piotr Jasiun

Status: assignedreview

Fixed. env.ie6Compat is now false for quirks mode in IE10 and everything seems to be fine.

git:8fdd7f3

comment:9 Changed 6 years ago by Piotrek Koszuliński

Status: reviewreview_failed
env.ie6Compat = version < 7 || (env.quirks && version != 10);

IE11 will not have QM? I guess it will.

comment:10 Changed 6 years ago by Piotr Jasiun

I'm not sure if IE11 will still have env.ie == true, but good point. I changed it t/9654.

comment:11 Changed 6 years ago by Piotr Jasiun

Status: review_failedreview

comment:12 Changed 6 years ago by Olek Nowodziński

Status: reviewreview_passed

I rebased the branch o master and fixed code-style. The UI still doesn't look perfect but the editor is working with this fix.

comment:13 Changed 6 years ago by Piotr Jasiun

Resolution: fixed
Status: review_passedclosed

Merged into master git:0fb7afe

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy