Opened 7 years ago

Closed 5 years ago

#9653 closed Bug (fixed)

Problems with IE10 Quirks mode

Reported by: Benjamin Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: IE10 Cc:

Description

CKeditor 3.6.5 is not working in IE10 (Windows 7 and Windows 8) if there are no or wrong doctype declarations.

Internet Explorer 10 returns to Quirks mode if there are errors in the declaration of html doctype. In the IE10 Quirks mode CKEditor is not working.

<html>
<head>
<script type="text/javascript" src="ckeditor/ckeditor.js"></script>
<title>CKEditor</title>
</head>
<body>
	<textarea id="story" name="story" class=""></textarea>
</body>
	<script type="text/javascript" type="javascript">
	//<![CDATA[
		CKEDITOR.replace ('story');
	//]]>
	</script>
</html>

Attachments (2)

ckeditor_ie10.png (75.1 KB) - added by Benjamin 7 years ago.
CKEditor in IE10 Quirks mode
test_quirks.html (313 bytes) - added by Jakub Ś 7 years ago.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by Benjamin

Attachment: ckeditor_ie10.png added

CKEditor in IE10 Quirks mode

Changed 7 years ago by Jakub Ś

Attachment: test_quirks.html added

comment:1 Changed 7 years ago by Jakub Ś

Keywords: IE10 added
Status: newconfirmed
Version: 3.6.53.0

This particular problem can be reproduced in IE10 only from CKEditor 3.0 - current trunk.

In CKEditor 4.x this particular problem does not occur but there are two others which were described here #9654 and #9655

comment:2 Changed 6 years ago by Frederico Caldeira Knabben

The problem is that IE10 introduced a new kind of default quirks mode, which is totally different than the one in previous versions.

Right now, if you really wants quirks on your pages, the only solution is using a valid quirks (HTML4) doctype or use the "X-UA-Compatible" meta accordingly:

<meta http-equiv="X-UA-Compatible" content="IE=5">

Of course, we recommend going with a modern doctype (HTML5).

comment:3 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

We fixed this in CKEditor 4.3.1 (#11182) or earlier.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy