Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#10453 closed Bug (invalid)

Keystrokes don't work for custom plugins

Reported by: Jakub Ś Owned by:
Priority: Normal Milestone:
Component: Core : Keystrokes Version: 4.0 Beta
Keywords: Cc:

Description

This is the second time I encounter this problem. User has sent me his custom plugin for v3. I have changed it to work with v4 but for some reason keystroke checks that worked in v3 don't work anymore in v4.

To reproduce:

  1. Use below code in replaebycode sample
    CKEDITOR.replace( 'editor1', {
    	extraPlugins : 'en_nbsp'		
    });
    
  2. Copy attached plugin folder for v4 and paste it into plugins folder.
  3. Load page and try to insert   with Ctrl+space

Either I have missed something simple or there is a problem in editor. Any explanations are welcome.

NOTE: There is also feature #8619 - perhaps it could be implemented while fixing this one.

Attachments (2)

v3.zip (547 bytes) - added by Jakub Ś 7 years ago.
v4.zip (608 bytes) - added by Jakub Ś 7 years ago.
Working version

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by Jakub Ś

Attachment: v3.zip added

comment:1 Changed 7 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 7 years ago by Piotrek Koszuliński

Resolution: invalid
Status: confirmedclosed

The en_nbsp plugin from v4 works for me perfectly fine on FF and Chrome after one change - there should be:

ev.data.preventDefault();

Version from v3.zip works too after removing:

requires : [ 'keystrokes' ],

There's no such plugin in v4.

Changed 7 years ago by Jakub Ś

Attachment: v4.zip added

Working version

comment:3 Changed 7 years ago by Jakub Ś

You are right I have added ev.data.preventDefault(); and it works perfectly.

I'm not sure why hasn't it worked before as even after removing this line spaces are still inserted.

I have uploaded working plugin sample for v4.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy