Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10478 closed Bug (duplicate)

Underlining on text isn't coloured

Reported by: AndyMillne Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.6
Keywords: Cc:

Description

If you create some coloured text in the editor and then attempt to apply an underline to the entire section of coloured text, the underlining is added in black.

If you select part of the coloured text however and then underline, the correct colour is added to the underline.

The issue also does not occur if the text is first underlined and then coloured.

Change History (2)

comment:1 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

This is a duplicate of #5503.

comment:2 Changed 6 years ago by Jakub Ś

@AndyMillne what you see is correct HTML behaviour. If u tag i s outside of span that adds colours then this is what you will see.

Unfortunately there is no other way at the moment but to use tags in order which is causing desired effect. We have this issue reported but it is very complicated task thus it won't be implemented anytime soon.

For your case you could use another span to colour whole - then you would end up with span u span text. Another not desired solution but like I said currently there is no other way.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy