Opened 6 years ago

Closed 6 years ago

#10528 closed Bug (wontfix)

ckeditor.js adds a "cursor:col-resize" style to the body tag

Reported by: Jesse Beach Owned by:
Priority: Normal Milestone:
Component: General Version: 4.1 RC
Keywords: Drupal Cc: wim.leers, wim.leers@…

Description

I noticed on the ckeditor configuration page in the latest Drupal 8 build that the cursor on the page is a resize handle. Looking into this further, it turns out that ckeditor.js is added a cursor style to the body tag. I'm not sure why this is happening, but it seems a bit over-general as a behavior.

Attachments (2)

Screenshot_6_10_13_12_58_PM.png (124.9 KB) - added by Jesse Beach 6 years ago.
Screenshot of the Google dev tools showing where there cursor:col-resize style is added to the body tag
Screenshot_6_10_13_12_58_PM.2.png (296.6 KB) - added by Jesse Beach 6 years ago.
Screenshot of the Chrome developer tools showing the cursor:col-resize style added to the body tag of the page.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by Jesse Beach

Screenshot of the Google dev tools showing where there cursor:col-resize style is added to the body tag

Changed 6 years ago by Jesse Beach

Screenshot of the Chrome developer tools showing the cursor:col-resize style added to the body tag of the page.

comment:1 Changed 6 years ago by Wim Leers

Cc: wim.leers@… added
Keywords: Drupal added

comment:2 Changed 6 years ago by Piotrek Koszuliński

Status: newpending

The cursor: col-resize style is indeed added by CKEditor but only in tableresize plugin. Once for the table resize handler and second time for body of the editor's contents. But it is done only when resize handler is hovered and in case of framed editor (I don't know which one do you use) not for the host document body, but the iframed one.

So I rather think that this style is added by Drupal's D&D toolbar builder, e.g. when hovering toolbar groups separators. Could this be true?

comment:3 Changed 6 years ago by Frederico Caldeira Knabben

I've investigated this issue a bit and in fact we have problems with the tableresize plugin and inline editing.

The tableresize plugin has been coded when we had framed editors only and has never been made compatible with inline. In inline it activates the table resizer for all tables in the page, no matter if they're inside or outside the editable element.

I've just tried it… adding a table to inlineall and voila… you can resize that table as well.

Still, it is strange that you're having the cursor constantly set in the page, because the tableresize plugin does that only briefly. It sets the cursor when moving over a "pillar" and resets it when moving out.

To avoid issues, for now, I would recommend removing the tableresize plugin when inline editing is required.

comment:4 Changed 6 years ago by Jesse Beach

Resolution: wontfix
Status: pendingclosed

fredck, thank you for looking into this. Know what to look for is very helpful.

I'm going to resolve as 'wontfix'. I can't reproduce the behavior on the latest patch for the ckeditor feature syncing. If the behavior re-emerges, we'll know where to look and perhaps how to remediate it.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy