Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10529 closed Bug (worksforme)

CKBuild custom output not playing as Framed Editor - no editor showing

Reported by: Steve Lawson Owned by:
Priority: Normal Milestone:
Component: Project : CKBuilder Version: 4.1.2
Keywords: Cc:

Description

I have tired about 5 different configurations of the CKBuilder [standard with one or more different combinations of optional plugins] as a "Framed Editor" [using a <textarea> element] and in every case, the textarea box vanishes and NOTHING shows up in it's place. When I do the same with the Standard Download Download CKEditor 4.1.2? the textarea vanishes and the editor shows up in it's place (in other words, it functions correctly).

In the later case (the CKBuilder installs where the editor doesn't show up), FireBug shows the following (FYI: the "style="visibility: hidden;" was not present, initially):

  <form>  
    <textarea style="visibility: hidden;" cols="80" id="editor1" name="editor1" rows="10">                
    </textarea>
  </form>
  <script type="text/javascript">
    CKEDITOR.replace( 'editor1' );
  </script>

[even after waiting a minute or two, the editor doesn't appear]

I was able to get it to work with the Standard download, so apparently I'm installing it and coding it correctly. It's only when I use CKBuilder that it doesn't work.

Win7 Firefox 21.0

Attachments (2)

build-config.js (1.6 KB) - added by Steve Lawson 6 years ago.
build-config.js as requested
10529_01.zip (161.0 KB) - added by Steve Lawson 6 years ago.
ZIP file containing requested information

Download all attachments as: .zip

Change History (10)

comment:1 Changed 6 years ago by Wiktor Walc

  1. Could you provide build-config.js from the package that does not work (it's in ckeditor folder)?
  1. Check in Firebug if you see any JavaScript or HTTP errors there. The optional 3rd party plugin may be triggering this issue.
  1. Does the replacebycode.html sample work in the custom build at least?

comment:2 Changed 6 years ago by Jakub Ś

Status: newpending

I have tried few (lucky pick) configurations but none of them produced error.

@ReverseEMF - please replay to all @wwalc questions and provide needed files otherwise we won't be able to do anything here.

Changed 6 years ago by Steve Lawson

Attachment: build-config.js added

build-config.js as requested

Changed 6 years ago by Steve Lawson

Attachment: 10529_01.zip added

ZIP file containing requested information

comment:3 Changed 6 years ago by Steve Lawson

  1. Attached build-config.js
  2. Yes, there are errors. I used Console Export to capture them and then ZIPped it with the ckeditor.js file that it references (and I added build-config.js, because it looked like only one attachment was allowed, but I learned otherwise :P (Noob-error!)
  3. The replacebycode.html sample doesn't work, either.

comment:4 Changed 6 years ago by Wiktor Walc

Okay, just to have all the necessary info: the broken build was created online @ http://ckeditor.com/builder is that right?

Is it possible that you had a page/tab with online builder opened for a longer period of time (e.g. a couple of hours) on Monday? It looks to me that you hit an error that has been fixed just a couple hours before the release of 4.1.2. Having the old invalid JS code from ckeditor.com website in your browser caused that for your browser this bug was still present and and invalid package with missing dependency was created.

I used your build-config.js to easily recreate the same package (using the button in the top right corner of http://ckeditor.com/builder) and the main reason of why your build was broken is gone: the missing panel plugin has been included in the release.

Could you try doing the same? Make sure to clear browser cache first, or at least refesh the page with builder.

comment:5 Changed 6 years ago by Steve Lawson

More than possible -- that appears to be what happened -- I was merely a victim of bad timing ;)

I tried using CKBuilder @ http://ckeditor.com/builder again, loaded it with a bunch of plugins and it WORKED!

So, this appears to be resolved -- thank you.

comment:6 Changed 6 years ago by Wiktor Walc

Resolution: worksforme
Status: pendingclosed

Thank you for the confirmation!

@anyone interested: it was exactly the same issue as described in #10526.

comment:7 Changed 6 years ago by Steve Lawson

Sorry, my searches didn't find #10526.

comment:8 Changed 6 years ago by Wiktor Walc

No problem at all! Without providing all the details as you did, it would be much harder to understand what was going on. So... feel free to report bugs in the future ;-)

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy