Opened 6 years ago

Closed 6 years ago

#10543 closed Bug (invalid)

EnterBR - BR isn't respected for the first line when ShiftEnterP is used

Reported by: Jakub Ś Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Cc:

Description

I have found this when reproducing #10537

  1. Configure editor in the following way:
    var editor = CKEDITOR.replace( 'editor1', {	
    				    toolbar:[
    						[ 'Source' ], [ 'Bold', 'Italic' ]
    					],
    					enterMode : CKEDITOR.ENTER_BR,
    					shiftEnterMode : CKEDITOR.ENTER_P		
    			});			
    
  2. In editor type "test", press Shift+Enter, type "test2"
  3. Switch to Source

Result: <p>test</p><p>test2</p>
Expected: test<p>test2</p>

NOTE: For every other line modes work i.e. they insert proper tags.
Because of this I have doubts if this is bug because this may be simply how editor works - “there is no BR separating lines but there is P below so wrap both in P”

Any comments are welcome.

Problem can be reproduced from CKEditor 3.0 till present (4.1.2)

Change History (2)

comment:1 Changed 6 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: confirmedclosed

This is how editor works and how it makes sense to work :).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy