Opened 6 years ago

Closed 5 years ago

#10569 closed New Feature (duplicate)

[IE] Can't select/delete multiple (empty) rows in a table

Reported by: vosmanz Owned by:
Priority: Normal Milestone:
Component: Core : Tables Version: 3.0
Keywords: IE Cc:

Description

In IE, it is not possible to select multiple empty rows in a table. Because of that, it is impossible to delete multiple empty rows at once.

Tested in IE 8/10. It works fine in the latest stable versions of Chrome(27) and Firefox(21) using Windows 8. In Opera (12.15) it is harder to select multiple rows, but it is possible there.

Tested in CKEditor 3.6.6, latest stable(demo, 4.1.2) and nightly.

Steps to reproduce:

  • Open ckeditor.com/demo
  • Empty the demo page
  • Add a table with the default settings
  • Try to select 2 rows. This will work in Chrome/Firefox, but not in IE.

When you add a space or another character in the first colomn of each row, it is possible to select more rows and delete them.

Attachments (1)

replacebycode.html (8.5 KB) - added by Jakub Ś 5 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 6 years ago by Jakub Ś

Keywords: IE added
Status: newconfirmed
Type: BugNew Feature
Version: 3.0

This is IE issue. It isn't possible to select, delete or copy empty table cells.

This issue is very similar issue to #4130.

Currently this is a "won't fix" issue, yet I'm changing it into Feature as it may get implemented in the future (Perhaps when we introduce our own selection).

comment:2 Changed 5 years ago by Jakub Ś

The problem is that IE doesn't allow selecting empty table cells. I have prepared workaround that some of you will perhaps find usefull. Please see attached file.

Changed 5 years ago by Jakub Ś

Attachment: replacebycode.html added

comment:3 Changed 5 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

DUP of #8830

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy