Opened 6 years ago

Closed 6 years ago

#10570 closed Bug (invalid)

element IDs are omitted from pasted or manually edited content

Reported by: Zoltan Koszegi Owned by:
Priority: Normal Milestone:
Component: General Version: 4.1.1
Keywords: oracle Cc:

Description

ID attribute of elements are omitted during paste. Also are omitted after edited an element in source view. E.g.: Let's have a list and add an ID to it in source mode: <li id="cite_note-5">window</li> when we switch back to wysiwyg and back to source again the id "cite_note-5" disappears. This happens also during paste when a clipboard HTML content has element IDs. Any element with an ID can be an anchor element. So a page can contain relative links to them. But CK deletes these IDs and the relative links brakes.

An addition question about this: Now CK seems to support only links to anchors (<a> tags) with an ID but to no other elements with an ID. If CK would keep other elements ID (eg during paste) would it be possible to make relative links (anchors) to those element IDs?

Change History (1)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: newclosed

It's not a bug - it's a feature ;)

Read about filtering here: Advanced Content Filter guide.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy