Opened 6 years ago

Closed 6 years ago

#10599 closed Bug (fixed)

Remove "indent" require from "list" plugin

Reported by: Frederico Caldeira Knabben Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 4.2
Component: Core : Lists Version:
Keywords: Cc:

Description

The list plugin has a require for the "indent" plugin. This require sounds unnecessary and, other than this, it may be even wrong, after the changes promoted with #10027.

This require must be reviewed and either removed altogether (best option) or replaced with the new "indentlist".

Change History (5)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: newassigned

comment:2 Changed 6 years ago by Frederico Caldeira Knabben

Owner: changed from Piotrek Koszuliński to Frederico Caldeira Knabben

comment:3 Changed 6 years ago by Frederico Caldeira Knabben

Status: assignedreview

Pushed t/10599 @cksource and @tests.

To start off, I've removed all "indent" entries from the "cktester-plugins" meta of list tests. Everything worked fine.

Then, I've removed that requirement altogether and we had some reds.

The root of the problem is that we have a execCommand( 'outdent' ) call in the list plugin code. There were also some ACF issues in the indentlist plugin.

To make it simple for now, I'm replacing the "indent" require with "indentlist". The ACF issues got fixed instead.

I also removed some tests that are not anymore compatible with the plugins requirement setup that is proposed by this fix. In any case, requiring "indentlist" in the "list" plugin still doesn't sound like right, so a new ticket will be opened for it as soon as this one gets closed. At that point, the removed tests should get re-introduced.

comment:4 Changed 6 years ago by Piotrek Koszuliński

Status: reviewreview_passed

comment:5 Changed 6 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: review_passedclosed

Fixed with git:8ac6a22.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy