Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#10604 closed Bug (duplicate)

[IE11] Unable to close CKEditor dialogs

Reported by: frietsch Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version: 4.0
Keywords: IE11 Cc:

Description (last modified by Jakub Ś)

As the release of IE11 is getting closer (scheduled for shipping with Windows 8.1 in August - seems that Microsoft is in a hurry...), I thought that it's a good idea to test-drive CKE.

Unfortunately, my test drive didn't get far, as I can't close any CKEditor dialog that I open (e.g. link, picture). The F12 tools report a lot of "access denied" errors.

I can see the problem both on the 4.x demo page and in v3.6.6, which is still our production version (and has more IE11 problems, but I can understand that nobody will fix them for that old version).

Haven't found the time to debug in deep until now, but that might be related with "IE hacks" no longer applying.

Microsoft has changed the user agent to get rid of old hacks: http://www.nczonline.net/blog/2013/07/02/internet-explorer-11-dont-call-me-ie/

Testing IE11 is rather easy. The official ISO images of Windows 8.1 can be downloaded from: http://windows.microsoft.com/en-us/windows-8/preview-iso The product key is also mentioned on that page. Afterwards, it can be installed in VirtualBox, which requires a small patch, depending on its version: https://blogs.oracle.com/fatbloke/entry/using_virtualbox_to_test_drive

Edit: I was able to reproduce this for Image, Link and Flash Dialogs . When you open one of these dialogs you get permission denied error.

Attachments (1)

WindowsProblemRecorder.zip (565.4 KB) - added by frietsch 6 years ago.
Screen recording of the problem

Download all attachments as: .zip

Change History (24)

comment:1 Changed 6 years ago by Frederico Caldeira Knabben

Keywords: IE11 added

comment:2 Changed 6 years ago by frietsch

Found a few time to "play around". I edited some lines in env.js and fixed the conditions for env.ie (by matching for "trident", too), env.gecko (by excluding if env.ie) and hard-coding the IE version to 10 (as my user agent contains no IE version at all, just a number for the trident engine).

As the result is a totally empty page (with no CKEditor at all), I guess that more expert knowledge is needed. In worst case, it's more than just detection, then real changes have to happen for IE11.

comment:3 Changed 6 years ago by Frederico Caldeira Knabben

Status: newpending

Thanks for the details, frietsch.

I think you already noticed the main ticket I've opened for IE11 (#10612), based on your suggestion (thanks2 :)).

In any case, I had no problems closing dialogs. Is there any special steps to be able to reproduce it?

Changed 6 years ago by frietsch

Attachment: WindowsProblemRecorder.zip added

Screen recording of the problem

comment:4 Changed 6 years ago by frietsch

Yes, I noticed the main ticket; thanks for caring!

I don't need special steps to reproduce the Problem. I've attached a Screen recording by "psr" (hardly known but included in Windows since Win7). Neither [x], OK or Cancel Buttons work. I simply opened the Picture Dialog. IE11 got some patches today, which are installed in my VM.

And sorry for the weird capitalization of words. IE11 does this automatically?!

comment:5 Changed 6 years ago by frietsch

Ah, BTW: My user Agent is

Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko

I've seen blog Posts mentioning at least some "IE" in it, but there is None for me. Just "Trident" to match...

comment:6 Changed 6 years ago by Frederico Caldeira Knabben

Status: pendingconfirmed

I was able to confirm this. It happens with the "Image" and "Link" dialogs only. Other simpler dialogs work well.

comment:7 Changed 6 years ago by Jakub Ś

Version: 3.6.6 (SVN - trunk)4.0

I was able to reproduce this for Image, Link and Flash Dialogs

comment:8 Changed 6 years ago by Jakub Ś

Description: modified (diff)

comment:9 Changed 6 years ago by Piotrek Koszuliński

Resolution: duplicate
Status: confirmedclosed

I'm closing this as a DUP of #10612, because it's fixed by initial t/10612b's commit and I want to clean up a little bit.

comment:10 Changed 5 years ago by bitpath

Hi, I just wanted to confirm this still appears to be happening. Using current IE11 on Windows 7. At first I thought CKEditor was broken or did not work, testing it, since I could not get out of image or link dialogues. Tried FireFox and now I can see how it works and it seems great. In IE11 on same machine, clicking on "OK", "Cancel" or corner "X" to get out of dialogues would do nothing, just leave you stuck in link or image edit dialogue. Windows and IE patches are current through 7/8/2014 (today) as of writing this. Possible Correction - I apologize. I am using ckeditor plugin for WordPress. I will go there and reference this ticket in case it's just WordPress plugin that did not catch this fix. Thank you.

Last edited 5 years ago by bitpath (previous) (diff)

comment:11 Changed 5 years ago by Piotrek Koszuliński

It can't be the same issue as described in this ticket, unless you use old version of CKEditor. Please upgrade your CKEditor installation if you don't use the latest version and report a new ticket. In it, please describe a step by step scenario and how CKEditor is used (package, version, whether jQuery UI is used on the same page, etc).

comment:12 in reply to:  11 ; Changed 5 years ago by bitpath

Replying to Reinmar:

It can't be the same issue as described in this ticket, unless you use old version of CKEditor. Please upgrade your CKEditor installation if you don't use the latest version and report a new ticket. In it, please describe a step by step scenario and how CKEditor is used (package, version, whether jQuery UI is used on the same page, etc).

I am using the wordpress plugin at http://wordpress.org/plugins/ckeditor-for-wordpress/ It does use an older version of CKEditor I assume since it was last updated 12/2012.. I will see how to update it on my own install as the wordpress repository seems very out of date. There is no trick to usage, the version there just does not let you escape out of the link and image dialogues once you click them when using ie11. Also I just realized my experience is apparently the old version from 2012. I look forward to trying to integrate the current one with wordpress. Not to be off topic, this old bug brought me here, but there an official maintained wordpress plugin or is trying to get that one updated the best way, or is there another preferred action I should try? thanks!

Last edited 5 years ago by bitpath (previous) (diff)

comment:13 in reply to:  12 ; Changed 5 years ago by bitpath

Replying to bitpath:

Replying to Reinmar:

It can't be the same issue as described in this ticket, unless you use old version of CKEditor. Please upgrade your CKEditor installation if you don't use the latest version and report a new ticket. In it, please describe a step by step scenario and how CKEditor is used (package, version, whether jQuery UI is used on the same page, etc).

Sorry. I just realized this is all you were asking. I am using the wordpress plugin at http://wordpress.org/plugins/ckeditor-for-wordpress/ which is outdated since 12/2012. Can you let me know the best path from here? Is there an official plugin or is there a better, more official way to integrate ckeditor into wordpress I can help pass along? Many of us are having issues with the new TinyMCE4 integrated in the latest WP and even the old CKEditor plugin from 2012 has some features that might help people, but the plugin they have posted is old and from 2012 with other bugs that are very likely fixed in new CKEditor. Thank you for any guidance.

comment:14 in reply to:  13 Changed 5 years ago by Frederico Caldeira Knabben

Replying to bitpath:

I am using the wordpress plugin at http://wordpress.org/plugins/ckeditor-for-wordpress/ which is outdated since 12/2012. Can you let me know the best path from here? Is there an official plugin or is there a better, more official way to integrate ckeditor into wordpress I can help pass along?

I don't think there is nothing more "official" than that. We can see that the guys there are "looking for maintainers", so stepping in to help would be your best move. Good luck!

comment:15 Changed 5 years ago by garima

Hi,

I am working on liferay 6.1.0 and liferay is using CKEditor 3.5.3 , I am unable to close CKEditor dialogs when open the site in IE11.It happens only with the "Image" and "Link" dialog . I have done the changes mention in Github(https://github.com/ckeditor/ckeditor-dev/commit/8eb1a58) but selection.js is not their in ckeditor folder.

Please reply.Its urgent

Thanks, Garima

comment:16 in reply to:  15 Changed 5 years ago by frietsch

Replying to garima:

Please reply.Its urgent

Please, guys...

Stop posting bug reports for ancient CKEditor versions. It is clearly mentioned here that this problem is fixed in the CKEditor 4.x branch. So go ahead, and update! If you don't know how, read the docs, it's rather easy. And if CKEditor is integrated in something else you are using, go blame the authors of that "else" for shipping a that old version of CKEditor. Or pay someone that can update CKEditor for you.

(I'm not related to the CKEditor team in any way, but I get a mail about each reply here, and this is my honest opinion...)

comment:17 Changed 5 years ago by frietsch

If anyone can give me a hint how to remove myself from this issue's CC list, I'm happy to read it :-)

comment:18 in reply to:  17 ; Changed 5 years ago by bitpath

Replying to frietsch:

If anyone can give me a hint how to remove myself from this issue's CC list, I'm happy to read it :-)

I wouldn't be rude to people who might not know the same specifics of the issue, personally, and I don't know how you configure this system's notices. I didn't even know it was an "old issue" until I investigated more. If it were me that was no longer interested in posts for this thread though, it's super simple and easy in nearly every email client or server based webmail to create a rule to discard or file these. The emails for a specific ticket all seem to have the same header....

comment:19 in reply to:  18 ; Changed 5 years ago by frietsch

Replying to bitpath:

Replying to frietsch: I wouldn't be rude to people who might not know the same specifics of the issue

OK, my mood isn't the best today in general, but anyone reporting a bug should do some investigation in available documentation before. For example: http://docs.ckeditor.com/#!/guide/dev_issues_readme Does the demo page show the problem? No? Well, because CKEditor has passed release 3.5 since ages...

If it were me that was no longer interested in posts for this thread though, it's super simple and easy in nearly every email client or server based webmail to create a rule to discard or file these. The emails for a specific ticket all seem to have the same header....

Sure, possible. Of course, solving the source of the problem would be better, but a good point.

comment:20 in reply to:  19 Changed 5 years ago by bitpath

I agree. Actually unchecking ticket notices would be better, and I'd be interested in knowing where that is too. Garima, As mentioned, CKEditor is onto versions 4.x now, and the link for the fix you are referring to is also a fix for 4.x versions which may be why other pieces are missing. I think revision fixes posted only apply to that branch and directly preceding versions, dozens of other things could have been fixed between now and then also affecting your issue. friestsch is right. You should update to 4 before applying bug fixes specific to 4 versions. I'm not affiliated with CKEditor either. I also don't know enough to help with your issue, other than the same advice. Upgrade fully to 4, ask the maintainer of your 3rd party integration to do so, or pay someone to do it. Thanks

Replying to frietsch:

Replying to bitpath:

Replying to frietsch: I wouldn't be rude to people who might not know the same specifics of the issue

OK, my mood isn't the best today in general, but anyone reporting a bug should do some investigation in available documentation before. For example: http://docs.ckeditor.com/#!/guide/dev_issues_readme Does the demo page show the problem? No? Well, because CKEditor has passed release 3.5 since ages...

If it were me that was no longer interested in posts for this thread though, it's super simple and easy in nearly every email client or server based webmail to create a rule to discard or file these. The emails for a specific ticket all seem to have the same header....

Sure, possible. Of course, solving the source of the problem would be better, but a good point.

comment:21 in reply to:  19 Changed 5 years ago by garima

Ckeditor 3.5 is being used as a third party tool in my portal and its not possible for me to upgrade it to version 4. I didn't found any thing in forums related to version 3 , so I thought I may get some help from here. Anyways thanks for reply Frietsch and Bitpath.

Replying to frietsch:

Replying to bitpath:

Replying to frietsch: I wouldn't be rude to people who might not know the same specifics of the issue

OK, my mood isn't the best today in general, but anyone reporting a bug should do some investigation in available documentation before. For example: http://docs.ckeditor.com/#!/guide/dev_issues_readme Does the demo page show the problem? No? Well, because CKEditor has passed release 3.5 since ages...

If it were me that was no longer interested in posts for this thread though, it's super simple and easy in nearly every email client or server based webmail to create a rule to discard or file these. The emails for a specific ticket all seem to have the same header....

Sure, possible. Of course, solving the source of the problem would be better, but a good point.

comment:22 Changed 5 years ago by bitpath

I hate to give this advice here of all places, but I found little help either that I could readily understand and afford, so.. I also recommend trying the current tinymce integration if possible in your circumstance, and connecting with the current tinymce community working with your platform. https://issues.liferay.com/browse/LPS-40060?page=com.atlassian.streams.streams-jira-plugin:activity-stream-issue-tab Basically, I took the current tiny MCE and added integrations specific to wordpress, which I was using. I've never used liferay (that I know of), but in my situation it was much easier to make tweaks to the current tinymce version integrated with that situation... Basically, in my situate, ckeditor allowed copying and pasting of wysiwyg formats but had bugs in certain browsers. Current tinymce was current but specifically coded against wysiwyg copy and paste. It was easier just to code the exceptions I wanted in the currently integrated tinymce... :( If you need help I can't guarantee, but I love the learning learned by helping, so if you email admin@ bitpath.org, and it's not spammy i'll probably get it and do what little I can, within a week or so.. This is what I did to make currently integrated tinymce in wordpress work for me if it's any help http://wordpress.org/support/topic/paste-from-word-3?

comment:23 Changed 5 years ago by Jakub Ś

I am working on liferay 6.1.0 and liferay is using CKEditor 3.5.3 , I am unable to close CKEditor dialogs when open the site in IE11

@garima upgrading is the only option since IE11 has been supported since CKE 4.3.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy