Opened 6 years ago

Closed 6 years ago

#10632 closed Bug (invalid)

Pressing Backspace on IE9 in front of a link causes 2 characters to dissappear

Reported by: Filip Wieladek Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0.3
Keywords: IBM Cc:

Description

Steps to reproduce:

1) Go to the CKEditor demo site 2) Select Inline mode 3) Remove all text from a section of your choice 4) Enter Hello World 5) Make World a link to www.ckeditor.com 6) Put the cursor to the end of the world Hello 7) Press backspace

Expeceted Result: "d" is removed

Observed Result: "ld" is removed

This seems to be an issue with IE itself as can be seen in this fiddle: http://jsfiddle.net/mNB6P/

I would however expect CKEditor to fix the IE9 problem.

Attachments (1)

ie9Issue.mp4 (646.3 KB) - added by Filip Wieladek 6 years ago.
Screencast of the problem.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by Filip Wieladek

Attachment: ie9Issue.mp4 added

Screencast of the problem.

comment:1 Changed 6 years ago by Jakub Ś

Status: newpending

I wasn't able to reproduce this in demo page or locally. I have tried in default IE9.

Can anyone else check this?

comment:2 Changed 6 years ago by Filip Wieladek

Actually I think you are right. #

I develop on a linux box and only test on a VM with IE9. I ran into this problem on a VM where this issue happened only happened when deleting text in front of a link.

I retested the same issue on a native Windows 7 with a IE9 and it does not occur. I think it is safe to close the issue.

Thanks

comment:3 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy