Opened 6 years ago

Closed 6 years ago

#10651 closed Bug (duplicate)

CKEditor.NET - TextChanged event getting called on PreRender.

Reported by: Poornima Nookala Owned by:
Priority: Normal Milestone:
Component: Server : ASP.Net Version: 3.6.4
Keywords: Cc:

Description

As per asp.net page life cycle, control events should occur after Load() has executed. But, CKEditor is firing the TextChanged event on PreRender(). This is creating an issue where I click a button to update a page and need to get the text that has changed, but the TextChanged event occurs after button click event has executed, hence I am not able to capture text changes. The way TextChanged is implemented is not correct, I have attached the source where I have demonstrated the right way to implement it. It is documented in MSDN as well!

Attachments (1)

CKEditorControl.cs (57.9 KB) - added by Poornima Nookala 6 years ago.
ModifiedCKEditorControl.cs

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by Poornima Nookala

Attachment: CKEditorControl.cs added

ModifiedCKEditorControl.cs

comment:1 Changed 6 years ago by Jakub Ś

Keywords: TextChanged removed
Status: newconfirmed

I see you have commented //if (isChanged) OnTextChanged(e); and put it to RaisePostDataChangedEvent.

void IPostBackDataHandler.RaisePostDataChangedEvent()
{
  OnTextChanged(EventArgs.Empty);
} 

Thank you for reporting - we will have a look at it and check your solution.

BTW. is there any chance you could send us some simplified small application that shows problem you are having? IMHO It would be better to work on same code that is causing problems for you instead of creating/inventing our own.

comment:2 Changed 6 years ago by Marcus Lum

This is a duplicate of Ticket #9227

comment:3 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy