Opened 6 years ago

Closed 6 years ago

#10668 closed Bug (duplicate)

Safari: Unnecessary text displayed while pasting text copied from a word document

Reported by: Sachin Grover Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version:
Keywords: Cc: sacgrover@…

Description

When pasting a TEXT from Microsoft Word by using CTRL+V. Unnecessary text displayed with the content. I have attached screen shot of the issue for your reference .

Steps to reproduce:

  1. Copy text from Word using CTRL+C
  2. Go to http://www.fckeditor.net/demo and press CTRL+V in editor.
  3. You will see unnecessary text displayed.

Browser: Safari 5.1.7 OS: Windows Vista Starter

Attachments (1)

ckeditorInSafari.jpg (117.5 KB) - added by Sachin Grover 6 years ago.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by Sachin Grover

Attachment: ckeditorInSafari.jpg added

comment:1 Changed 6 years ago by Sachin Grover

following text is unnecessary:

Version:1.0 StartHTML:0000000168 EndHTML:0000001083 StartFragment:0000000471 EndFragment:0000001066

comment:2 Changed 6 years ago by Jakub Ś

Status: newpending

I paste into browsers from Word on daily basis. I have also tried using Vista an Safari 5.1.7 and didn't get such problem.

Could you please provide sample Word file that is causing this problem? Perhaps you have some non standard word setting that is causing this? Which version of Word you use?

comment:3 Changed 6 years ago by Sachin Grover

I used Openoffice. sorry I forgot to mention.

comment:4 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: pendingclosed
Version: 4.1

DUP of #8761.

I'm closing this issue as duplicate of larger one. CKEditor currently mainly supports MS Word. Other desktop editors work but may have some unexpected problmes. We plan to rewrite pastefromword filter to give better support to MS WORD and other desktop editors like Open Office.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy