Opened 6 years ago

Closed 6 years ago

#10703 closed Bug (invalid)

We have to press ESC twice to close Select Color dialog

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: Accessibility Version:
Keywords: IBM Cc: Damian, Teresa Monahan, Irina

Description

To reproduce the defect:

  1. with JAWS on, open any CK Editor sample & insert a table.
  1. Open Context menu and select Cell & Cell Properties to open Cell Properties dialog.
  1. On Cell Properties dialog, click on Choose button next to Border Color or Background Color text field
  1. Select Color dialog opens
  1. Press Esc.

Expected Result: Select Color dialog closes & focus goes back to Cell Properties dialog.

Actual Result: Select Color dialog not closed, we have to press ESC second time to get it closed.

We are using FF22 & JAWS14

Change History (5)

comment:1 Changed 6 years ago by Jakub Ś

Status: newpending

I have tested this on FF 23, Jaws 14 and Windows 7. I have also tried same browser with same JAWS on Vista 64-bit, Windows 8 and Windows XP.

I haven't observed problem you have described nowhere. One single Escape was enough to leave dialog.

  1. Are you still able to reproduce this in default editor and FF23?
  2. Perhaps there are some configuration options that need to be set?
Last edited 6 years ago by Jakub Ś (previous) (diff)

comment:2 in reply to:  1 Changed 6 years ago by Satya Minnekanti

Replying to j.swiderski:

I have tested this on FF 23, Jaws 14 and Windows 7. I have also tried same browser with same JAWS on Vista 64-bit, Windows 8 and Windows XP.

I haven't observed problem you have described nowhere. One single Escape was enough to leave dialog.

  1. Are you still able to reproduce this in default editor and FF23?
  2. Perhaps there are some configuration options that need to be set?

@j.swiderski i have tested again on nightly build with JAWS 14.0.6005 & FF23. This issue happens the first time you open Select Color dialog & with out performing any actions(Tab or Arrow keys) just press Esc. Select Color dialog not closes, we have to press Esc for the scone time to close it

comment:3 Changed 6 years ago by Jakub Ś

Could you please answer two things:

  1. On which system you test this?
  2. Are you using default editor freshly downloaded from our page or one integrated into your application?
  3. Which CKEditor version you test?

I was able to reproduce this issue once in CKEditor 4.2 in Windows 8 with JAWS 14 and FF23. I had to clean browsers cache, load replacebycode.html sample, apply your TC (Esc was pressed right after open). Like I have said - only once JAWS has read "Virtual PC Cursor" instead of closing the dialog.

comment:4 in reply to:  3 Changed 6 years ago by Satya Minnekanti

Replying to j.swiderski:

Could you please answer two things:

  1. On which system you test this?
  2. Are you using default editor freshly downloaded from our page or one integrated into your application?
  3. Which CKEditor version you test?

I was able to reproduce this issue once in CKEditor 4.2 in Windows 8 with JAWS 14 and FF23. I had to clean browsers cache, load replacebycode.html sample, apply your TC (Esc was pressed right after open). Like I have said - only once JAWS has read "Virtual PC Cursor" instead of closing the dialog.

@j.swiderski i can't reproduce this issue after clearing my cache. so you close this one

comment:5 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy