Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10704 closed Bug (fixed)

JAWS not reading Select Color dialog title when it's opened

Reported by: Satya Minnekanti Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 4.2.2
Component: Accessibility Version:
Keywords: IBM Cc: Damian, Teresa Monahan, Irina

Description

To reproduce the defect:

  1. with JAWS on, open any CK Editor sample & insert a table.
  1. Open Context menu and select Cell & Cell Properties to open Cell Properties dialog.
  1. On Cell Properties dialog, click on Choose button next to Border Color or Background Color text field

Expected Result: Select Color dialog opens, JAWS reads dialog title & then the first color option that receives focus

Actual Result: Select Color dialog opens but JAWS not reading dialog title, it just reads first color option & then it says Rich text editor press alt + zero for help. when we use arrow keys to go to next option then JAWS reads dialog tile & new color

We are using FF22 & JAWS14

Change History (10)

comment:1 Changed 6 years ago by Jakub Ś

Status: newpending

I have tested this on FF 23, Jaws 14 and Windows 7. I have also tried same browser with same JAWS on Vista 64-bit, Windows 8 and Windows XP.

In all cases Editor was reading:

  1. Not always "Rich text editor press alt + zero for help"
  2. Dialog title two times "Select Color Dialog"
  3. "Color Options Table"
  4. "Column 1 Row 1"
  5. "Number 000000"

I have tried that in default editor - could you please tell me what have I missed?

Last edited 6 years ago by Jakub Ś (previous) (diff)

comment:2 in reply to:  1 Changed 6 years ago by Satya Minnekanti

Replying to j.swiderski:

I have tested this on FF 23, Jaws 14 and Windows 7. I have also tried same browser with same JAWS on Vista 64-bit, Windows 8 and Windows XP.

In all cases Editor was reading:

  1. Not always "Rich text editor press alt + zero for help"
  2. Dialog title two times "Select Color Dialog"
  3. "Color Options Table"
  4. "Column 1 Row 1"
  5. "Number 000000"

I have tried that in default editor - could you please tell me what have I missed?

@j.swiderski i have tested again on nightly build with JAWS 14.0.6005 & FF23. When we open Select Color dialog for the first time, JAWS not reading dialog title, it just reads first color option & then it says Rich text editor press alt + zero for help.

when we open the dialog second time or any no of times with out closing the editor,JAWS reads dialog title, it reads first color option but then it says Rich text editor press alt + zero for help which is not correct.

comment:3 Changed 6 years ago by Jakub Ś

I have checked nightly version, my local version with JAWS 14, FF23, Windows 7/8 and still Color dialog was read. I can't reproduce this and see no problem here. Sure JAWS reads bunch of things but "Select Color Dialog" is either read first or second as explained in my last comment.

I have checked this on two machines. Could you perhaps do the same?

comment:4 in reply to:  3 Changed 6 years ago by Satya Minnekanti

Replying to j.swiderski:

I have checked nightly version, my local version with JAWS 14, FF23, Windows 7/8 and still Color dialog was read. I can't reproduce this and see no problem here. Sure JAWS reads bunch of things but "Select Color Dialog" is either read first or second as explained in my last comment.

I have checked this on two machines. Could you perhaps do the same?

JAWS now reads dialog title, but it reads Rich Text Editor, Press Alt + 0 for help before reading dialog title, which it should not do. This was working properly at 3.6.6 at http://rev.ckeditor.com/ckeditor/trunk/7695/_samples/replacebyclass.html. That issue of reading some garbage info before dialog title should be fixed.

comment:5 Changed 6 years ago by Jakub Ś

This is what editor reads now:

  1. Not always "Rich text editor editor1 frame, press alt + zero for help"
  2. Also not always "Edit press alt+ zero for help, type and text"
  3. Dialog title two times "Select Color Dialog"
  4. "Color Options Table"
  5. "Column 1 Row 1"
  6. "Number 000000"

As I understand it should not read point 1 and 2. Reading should start from point 3 (and dialog title should be read once only)

comment:6 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 4.2.2

comment:7 Changed 6 years ago by Frederico Caldeira Knabben

Owner: set to Frederico Caldeira Knabben
Status: pendingreview

I've just pushed t/10704 @ cksource with a small enhancement to it. It should always announce the dialog straight now.

Still I'm having an issue with the focus and navigation and this doesn't seem to be related to CKEditor because it works fine without JAWS. It randomly doesn't announce the first color, announcing instead "close button".

VoiceOver shows that we're properly focusing the color and even Firefox shows the focus dots on it. I think an intervention from FS would be required here.

In any case, I would ask to proceed with review on the provided code as it solves the dialog announcement problem and makes a step of improvement. As for the other issue, we may have a separate ticket.

comment:8 Changed 6 years ago by Olek Nowodziński

Status: reviewreview_passed

comment:9 Changed 6 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: review_passedclosed

Fixed with git:6f1232a.

comment:10 in reply to:  9 Changed 6 years ago by Teresa Monahan

Replying to fredck:

Fixed with git:6f1232a.

This fix works well. We cannot reproduce the issue where JAWS sometimes reads 'close button' instead of the first color.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy