Opened 6 years ago

Closed 6 years ago

#10705 closed Bug (fixed)

JAWS not reading label for Context menu & we can't navigate through options using keyboard

Reported by: Satya Minnekanti Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 4.2.2
Component: Accessibility Version: 3.2
Keywords: IBM Cc: Damian, Teresa Monahan, Irina

Description

To reproduce the defect:

  1. With JAWS on, open any CK Editor sample & insert a table.
  1. keep cursor inside a table cell and press Ctrl + Shift + F10 to open context menu

Expected Result: Context menu opens and JAWS read aria-label for Context menu which is Context Menu Options

Actual Result: JAWS just reads menu & says use arrow keys to navigate through options.

Press Down arrow key once.

Expected Result: Focus goes to first context menu option & JAWS read that option.

Actual Result: Focus not going to first content menu option,JAWS will read something like Group & when we press down arrow key few times JAWS started reading element path bar & elements in path bar and so on.

We are using FF22 & JAWS14

Change History (16)

comment:1 Changed 6 years ago by Jakub Ś

Status: newconfirmed
Version: 3.2

I have tested this on FF 23, Jaws 14 and Windows 7. I have also tried same browser with same JAWS on Vista 64-bit, Windows 8 and Windows XP.

JAWS doesn’t read "Context Menu Options" but something like "use arrow keys to navigate through options". This problem can be reproduced from CKEditor 3.2 and is present in CKEditor 4.2.

I see couple of problems here:

  1. JAWS not reading aria-label
  2. IMHO Editor should read the label but perhaps also "Press TAB to focus menu and use arrows to move through items". Reading only aria label doesn't tell users very much if they aren't familiar with menu. Current message is very misleading as it kind of suggests that user should press arrows to enter menu or that focus is already there.
  3. I'm not sure here as this may be some accessibility quirks and fixing it would be very complicated but despite what JAWS reads I don't think focus should be moved to elements path when arrow is pressed.

comment:2 Changed 6 years ago by Jakub Ś

Btw. "Press UP or Down arrow" is rather some JAWS default message. It isn't defined anywhere in CKEditor while i have seen it in JAWs documents e.g. http://www.freedomscientific.com/training/Surfs-Up/Forms.htm

comment:3 in reply to:  1 Changed 6 years ago by Satya Minnekanti

Replying to j.swiderski:

I have tested this on FF 23, Jaws 14 and Windows 7. I have also tried same browser with same JAWS on Vista 64-bit, Windows 8 and Windows XP.

JAWS doesn’t read "Context Menu Options" but something like "use arrow keys to navigate through options". This problem can be reproduced from CKEditor 3.2 and is present in CKEditor 4.2.

I see couple of problems here:

  1. JAWS not reading aria-label
  2. IMHO Editor should read the label but perhaps also "Press TAB to focus menu and use arrows to move through items". Reading only aria label doesn't tell users very much if they aren't familiar with menu. Current message is very misleading as it kind of suggests that user should press arrows to enter menu or that focus is already there.
  3. I'm not sure here as this may be some accessibility quirks and fixing it would be very complicated but despite what JAWS reads I don't think focus should be moved to elements path when arrow is pressed.

@j.swiderski we have tested ck editor 3.6 with FF17ESR & it's not reproducible. This issue only happens with FF23 . Also i noticed that in FF23 even with out JAWS when we open Context menu and press Aarrow keys focus not on Context menu, it's still in Editor body. This works properly in FF17 ESR.

comment:4 Changed 6 years ago by Jakub Ś

Could you define work properly?
At the moment with JAWS 14 (perhaps JAWS is doing this) you need to press TAB in order to focus menu, color dropdown or menu in toolbar. It has been working like that from CKEditor 3.5 (when focusing menu with TAB was made possible).
Only after pressing TAB one can navigate with arrows.

To be honest I don't remember how it worked with previous versions of JAWS so if anyone from CKSource or IBM could refresh my memory and leave a comment. Question - should menu be focused right after opening it with shortcut key or only after pressing TAB button and how it worked before?

If using TAB is correct than JAWS misleads users by reading its default message.

comment:5 in reply to:  4 Changed 6 years ago by Satya Minnekanti

Replying to j.swiderski:

Could you define work properly?
At the moment with JAWS 14 (perhaps JAWS is doing this) you need to press TAB in order to focus menu, color dropdown or menu in toolbar. It has been working like that from CKEditor 3.5 (when focusing menu with TAB was made possible).
Only after pressing TAB one can navigate with arrows.

To be honest I don't remember how it worked with previous versions of JAWS so if anyone from CKSource or IBM could refresh my memory and leave a comment. Question - should menu be focused right after opening it with shortcut key or only after pressing TAB button and how it worked before?

If using TAB is correct than JAWS misleads users by reading its default message.

Users should not have to press Tab to focus on the menu, the menu should already be focused when it's opened & pressing up/down arrow keys should visibly navigate menu options.. You can see this behavior at CK Editor 3.6.6 at http://rev.ckeditor.com/ckeditor/trunk/7695/_samples/replacebyclass.html

comment:6 Changed 6 years ago by Jakub Ś

@satya thank you for clarification.

The link you have pointed out didn't work for me either with JAWS. When JAWS is disabled there is no problem with pressing down arrow and focusing menu of any kind but if JAWS 14 is used then you can only focus menu(s) with tab.

My guess is that JAWS 14 has introduced some change that has “broken” editor all the way back.

comment:7 in reply to:  6 Changed 6 years ago by Satya Minnekanti

Replying to j.swiderski:

@satya thank you for clarification.

The link you have pointed out didn't work for me either with JAWS. When JAWS is disabled there is no problem with pressing down arrow and focusing menu of any kind but if JAWS 14 is used then you can only focus menu(s) with tab.

My guess is that JAWS 14 has introduced some change that has “broken” editor all the way back.

@j.swiderski, The issue with focus not going to Context menu even with out JAWS is only happening in Firefox 23 on CK Editor 4.x builds, it works fine for 3.6.x builds, Where as with Firefox 17 ESR focus goes properly to context menu in both 4.x & 3.6.x builds.

with JAWS 14 & FF17 ESR navigating context menu items works corectly in both CK Editor 4.x & 3.6.x

comment:8 Changed 6 years ago by Jakub Ś

I can't confirm this. In all browsers (without JAWS), after invoking context menu with keyboard shortcut, you have to press down arrow to see visible selection on context menu item. Only then you can execute such menu item.

I have verified it with cleared cache on demo page and my local default editor. It works the same everywhere except Opera Browser where focusing menu item after invoking it with keyboard doesn't work at all.

comment:9 in reply to:  8 Changed 6 years ago by Teresa Monahan

Replying to j.swiderski:

I can't confirm this. In all browsers (without JAWS), after invoking context menu with keyboard shortcut, you have to press down arrow to see visible selection on context menu item. Only then you can execute such menu item.

I have verified it with cleared cache on demo page and my local default editor. It works the same everywhere except Opera Browser where focusing menu item after invoking it with keyboard doesn't work at all.

@j.swiderski - I am seeing the same behavior as you without JAWS. I think Satya is using FF23.0 whereas I'm using FF23.0.1 - perhaps that is causing the different behavior.

Anyway with JAWS 14 on, it is not possible to navigate the context menu items in either CKEditor 4.x or 3.6.6 in FF23.x. However this does work well in FF17 ESR. Therefore this cannot be a JAWS related issue. Instead it looks like there was some change in FF between version 17 and 23 which has introduced this issue.

comment:10 Changed 6 years ago by Jakub Ś

What about TAB? In my tests in most browsers including Firefox (with JAWS turned on) you could focus menu with TAB. To enter submenu you have to press right-arrow and then tab. This is how it works now. Can you confirm it?

comment:11 Changed 6 years ago by Teresa Monahan

Yes, if you press TAB after opening the menu, you can then navigate the menu options and JAWS reads them out. However this step should not be required. It is not standard to have to press TAB in order to navigate menu items.

Also the aria-label for the menu is not read out when the menu opens.

comment:12 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 4.2.2

comment:13 Changed 6 years ago by Frederico Caldeira Knabben

Owner: set to Frederico Caldeira Knabben
Status: confirmedassigned

comment:14 Changed 6 years ago by Frederico Caldeira Knabben

This seems to be very related to #10706, so we'll wait for that ticket to have a conclusion first.

comment:15 Changed 6 years ago by Frederico Caldeira Knabben

Supposed to be fixed by #10951.

comment:16 Changed 6 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed by #10951.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy