Opened 6 years ago

Closed 5 years ago

#10758 closed Bug (expired)

Ooyala videos stuck on loading in Firefox

Reported by: Mandeep Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

I am trying to load ooyala vidoes using the flash plugin of inline ckeditor 4.0.2. Inside the flash dialog box the preview works very well in chrome, but it gets stuck on loading in Firefox.

Here is the fiddle demonstrating the issue(The fiddle has ckeditor 4.2 as I couldnt find a cdn for 4.0.2). http://jsfiddle.net/FLZhn/10/

and the embed url I am using to embed the video

https://player.ooyala.com/player.swf?embedCode=M4N2d1ZDoCBNpA7h7mbWZ8lEt1K9MSZw&version=3

I was able to reproduce this issue on your demo site as well using the full featured example(since flash option is not present for inline editor in the demo).

I am using chrome version 29 and firefox version 23

P.S. Surprisingly, it works properly in IE9

Attachments (3)

ooyala_video_on_ckeditor_demo_site.png (285.8 KB) - added by Mandeep 6 years ago.
ooyala_video_on_jsfiddle.png (279.5 KB) - added by Mandeep 6 years ago.
youtube_video_on_jsfiddle.png (349.6 KB) - added by Mandeep 6 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: newclosed

I checked linked jsfiddle and on Firefox only, after clicking "ok" in flash dialog editor crashes due to some errors:

[09:01:48.501] Error: Permission denied to access property 'toString'
[09:01:48.675] Error: Permission denied to access property 'parentNode' @ http://cdnjs.cloudflare.com/ajax/libs/ckeditor/4.2/ckeditor.js:54

However, I wasn't able to reproduce this issue locally or on http://ckeditor.com/demo#full. Only on jsfiddle it crashes and jsfiddle has a very specific way of rendering site which often causes some abnormalities and problems.

I'm closing this ticket for now. However, if you'll be able to reproduce the same problem in normal environment, please let us know and we'll reopen it.

Changed 6 years ago by Mandeep

Changed 6 years ago by Mandeep

Changed 6 years ago by Mandeep

comment:2 Changed 6 years ago by Mandeep

I am still able to reproduce it on the demo site. When I enter the url the preview gets stuck on loading(see attachment ooyala_video_on_ckeditor_demo_site.png​).

Yes the jsfiddle shows errors on pressing ok but I am not concerned as it works fine on my local. IMO the 'toString' error occurs because the code is running in an iframe as I also run an iframe at my local . The second error is specific to jsfiddle which I am not worried about as my issue is before pressing 'ok' where the video is stuck on loading in preview(see attachment ooyala_video_on_jsfiddle.png​).

The youtube video works fine inspite of the 'toString' error in Jsfiddle so I dont think 'toString' is the cause of the ooyala video getting stuck(see attachment youtube_video_on_jsfiddle.png​)

Last edited 6 years ago by Mandeep (previous) (diff)

comment:3 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: closedreopened
Version: 4.0.2

So you meant that preview is not loaded. Ok, I confirm this.

I'm not sure however, if we're going to work on this it, because it will be hard to debug whether it is editor's fault or not. And unless this issue concerns also other flash files it won't get high priority.

comment:4 Changed 6 years ago by Mandeep

I would like to add that its just not the preview. When I save the data using getData() method and save the code, the video is still stuck on loading when that code is rendered/shown on a page.

I know its hard but hope that you will get time to have a quick look into this. Thanks :)

comment:5 Changed 6 years ago by Mandeep

After debugging I found that in Firefox it also needs the flashvars property to run. In the flash plugin I cannot see any field which accepts a flashvars property. How can I add a flashvars property to the video to be embedded?

comment:6 Changed 5 years ago by Jakub Ś

Status: reopenedpending

@Mandeep Jain have you got any link that points to flash file that can be put in Browser URL and will work? Youtube has such links e.g. www.youtube.com/v/upE1gy_Qsfs?version=3&amp;hl=pl_PL but I haven't found any such links or even <object...<param... HTML code for ooyala that can be put in HTML page.

This could be similar issue to this one #5184 saying that editor flash plugin doesn't transform youtube page URLs butbefore making any judgement I would like to see some working freely available link that would work in browser (by pasting into URL bar).

comment:7 Changed 5 years ago by Piotrek Koszuliński

Resolution: expired
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy