Opened 6 years ago

Closed 6 years ago

#10774 closed Bug (duplicate)

Unclosed LI tags become indented on IE when inside a FONT tag

Reported by: Rick Schnorenberg Owned by:
Priority: Normal Milestone:
Component: Core : Parser Version: 4.2
Keywords: IE Cc:

Description

Description

List items that do not have their LI tag closed render differently if the OL is inside a FONT tag in Internet Explorer

Steps to Reproduce

  1. Launch the Nightly Editor Demo in IE (I tested against http://nightly.ckeditor.com/13-08-29-13-05/standard/samples/replacebyclass.html)
  2. Call setData on the editor with the following HTML
    <font>
    	<ol>
    		<li>item1
    		<li>item2
    		<li>item3</li>
    	</ol>
    </font>
    

Expected Behavior

The editor displays the following list:

1. item1
2. item2
3. item3

Actual Behavior

The editor displays the following list:

1. item1
    ● item2  
        ■ item3

System

I was able to reproduce this on IE 7,8,9 and 10

Chrome and Firefox were unaffected

Change History (1)

comment:1 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

This issue is a duplicate of #9740.

@rschnorenberg please note that code you have shown us is invalid. Such wrapping whole list (block element) in font (inline element) is invalid. Your code should rather look like:

<ol>
<li><font>item1</font>
<li><font>item2</font>
<li><font>item3</font></li>
</ol>

Nevertheless there is an issue in editor and this one duplicates #9740 so please refer to the former one.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy