Opened 6 years ago

Closed 6 years ago

#10775 closed Bug (duplicate)

Firefox deselects selected text when applying styles after ctrl + a (select all)

Reported by: sterlingw Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0 Beta
Keywords: Firefox Cc:

Description

From what I've seen, this only occurs if the source being edited is not surrounded by tags. More specifically, it happens when "BR on Enter mode" is enabled.

Using Firefox, with BR on Enter mode enabled, add some text to the editor (but no HTML). Then select all using CTRL + A. Apply a style (like bold, italics, or strikethrough). The style is applied, but then the selection is deselected and the cursor moves to the end of the selection. If multiple lines are used, then the cursor moves to the end of the first line.

To better illustrate, here is a screencast: http://screencast.com/t/qHwIf8WzNX

Change History (3)

comment:1 Changed 6 years ago by Jakub Ś

Keywords: Firefox added
Status: newconfirmed
Version: 4.24.0 Beta

Problem can be reproduced in Firefox only from CKEditor 4.0 beta (works fine in CKE 3.x).

comment:2 Changed 6 years ago by Jakub Ś

This is in fact a duplicate of #7830.

comment:3 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy