Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10781 closed Bug (duplicate)

CKEditor lose font when click outside editor and then clicks back to end of line

Reported by: Thiago Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Browser: Firefox 23.0.1 OS: Windows 7 Professional 32 bits

Note: This seems specific for Firefox, I was unable to reproduce it on IE.

Steps to reproduce:

  1. Go to CKEditor (http://ckeditor.com/demo#full)
  2. Clear all existing content.
  3. Select font Courier New (or any other available).
  4. Type some content like "Today is Monday and I have a lot of things to fix".
  5. Click outside the editor.
  6. Click now at the right of last word typed ( in this case "fix").

The result: Current font (Courier new) is lost and editor returns to default "Font" option. This also occurs for font size.

Attachments (2)

first.png (99.5 KB) - added by Thiago 6 years ago.
After type
second.png (108.9 KB) - added by Thiago 6 years ago.
After click outside the editor and click back.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by Thiago

Attachment: first.png added

After type

Changed 6 years ago by Thiago

Attachment: second.png added

After click outside the editor and click back.

comment:1 Changed 6 years ago by Piotrek Koszuliński

Keywords: font lost focus ckeditor removed
Resolution: duplicate
Status: newclosed
Version: 4.2

This is caused by the fact that caret may be outside or inside span applying that font style. Firefox places it outside (however it sometimes chooses inside...), so after you click, the font is lost.

This issue is already reported, but I can't find the ticket now.

comment:2 Changed 6 years ago by Piotrek Koszuliński

This is one of duplicates: #8416.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy