Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#10783 closed Bug (invalid)

Each copied Microsoft-style list can get pasted as multiple lists

Reported by: Zoltan Koszegi Owned by:
Priority: Normal Milestone:
Component: Plugin : Paste from Word Version:
Keywords: Oracle Cc:

Description

This relates to MsoListParagraph paragraphs (which become normal lists on paste, but with issues). Steps To Recreate:
1) Go to DEMO page (I used with IE9).
2) From the attached docx copy and paste the list below the "2. Repeating text after first line" title.
RESULT_1:
Instead of [a, a-sublist, b, c] we get [a, a-sublist], [a, b] => this is two separate lists instead of one.
3) From the attached docx copy and paste the list (containing a table) below the "Exclusion of parent list #2" title.
RESULT_2:
Instead of [1, 1-table, 2, 3] we get [1, 1-table], [1, 2] => this is two separate lists instead of one.

Attachments (5)

list-break2.docx (20.0 KB) - added by Zoltan Koszegi 6 years ago.
copy source .docx file
ck1.gif (7.9 KB) - added by Zoltan Koszegi 6 years ago.
sample source selection from docx
ck2.gif (4.2 KB) - added by Zoltan Koszegi 6 years ago.
sample paste result in CK-DEMO page
list-break2.htm (113.7 KB) - added by Zoltan Koszegi 5 years ago.
lists.png (39.7 KB) - added by Jakub Ś 5 years ago.

Download all attachments as: .zip

Change History (11)

Changed 6 years ago by Zoltan Koszegi

Attachment: list-break2.docx added

copy source .docx file

Changed 6 years ago by Zoltan Koszegi

Attachment: ck1.gif added

sample source selection from docx

Changed 6 years ago by Zoltan Koszegi

Attachment: ck2.gif added

sample paste result in CK-DEMO page

comment:1 Changed 5 years ago by Jakub Ś

Status: newpending
  1. I only had problems with [a, a-sublist, b, c]. Second one worked fine.
  2. I have tried creating such sample list in empty word document and it has worked without problems.

Could you please explain how to create list that causes such problems? Are you able to reproduce it regularly?

comment:2 Changed 5 years ago by Zoltan Koszegi

The docx is the source of this issue and I thought it is useful for you to have this. but I think it is too easy to get different results by combining different versions of Word as a source and different IE versions as a CKEditor destination. The bug was written about HTML-to-HTML in IE, so I would think it simplifies the issue to have you paste HTML-to-HTML in IE without any Word/Office applications involved so I attached an html file as well.

remark: Do not worry about the file format, the issue is reproducible by copying from the docx exactly the same way as if we had saved it into HTML.

Changed 5 years ago by Zoltan Koszegi

Attachment: list-break2.htm added

Changed 5 years ago by Jakub Ś

Attachment: lists.png added

comment:3 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed
Version: 4.2

Do not worry about the file format, the issue is reproducible by copying from the docx exactly the same way as if we had saved it into HTML.

I believe you didn't understood what I had in mind. I should make in clear in first post. I was asking how this list was created (clicked out) in Word.
My suspicion was that it was created more or less like this: "let me click here, indent, ... or not, I will do it about 100 times plus some extra non-standard indentation and list is ready but what do I see? It doesn't work in editor".
This is because I have created such list in my word 2010 (using only Word list and indent button) and it has worked. Furthermore, first list from your file also works.

Since you have mentioned HTML let me get to the bottom of this (I should have done it in first post - sorry for that).
Please have a look at attached image - this is code comparison from second and first list. Look at the elements inside - they have level 1 instead of level 2. That is why this singlelist (in word) is seen as two lists in browser and editor.

You most likely know that since this is how HTML looks like there is no error in editor. I'm closing this issue as invalid.

comment:4 Changed 5 years ago by Zoltan Koszegi

Actually the origin of this list comes from an email that was written in Outlook. Outlook has the same MS format as the Word has. So a content comes from Outlook or Word does not make any difference. The list was written by hand but the attached list was overwritten because the original list (email) contains confidential informations. I don't know why does it make sense where the document part comes from? It was created by hand and the issue can be reproduced on CK DEMO page.

comment:5 Changed 5 years ago by Jakub Ś

  1. Like I said before - list from your example doesn't have second level list items. This makes this example invalid and confirms editor is working as expected. Have you by any chance checked attached screen?
  1. You claim that you are able to reproduce this problem in CKEditor demo. How? Are you able to create regularly sample list by hand and get this result in demo or by reproducing you mean copying list provided in your example?
  1. >>I don't know why does it make sense where the document part comes from?
    Simple - i have learned few times that it is possible to create in Word list structures that don’t look as expected in browser. In such cases it is best to create list once more. That is why I have asked you how this list was created because I'm 99% certain that it was created as described above. Anyway at this point it doesn't matter where and how it was created. List is seen as two by Browser and there is nothing we can do here.

comment:6 Changed 5 years ago by Frederico Caldeira Knabben

Component: GeneralPlugin : Paste from Word
Keywords: Oracle added; oracle removed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy