Opened 12 years ago

Closed 11 years ago

#1083 closed Bug (wontfix)

Cursor is placed outside of table but not inside next/previous paragraph

Reported by: Jon Håvard Gundersen Owned by:
Priority: Normal Milestone: FCKeditor 2.6.1
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed IE Discussion Cc:

Description (last modified by Martin Kou)

Scenario:

  1. Create a table
  2. Click the mouse outside of the table (either just before or after)
  3. The cursor is placed outside of the table at the height of the last row
  4. When starting to write the cursor is moved to the correct position (either into the paragraph above or the paragraph below).

Tested in nightly build with IE7

The wrongly placed cursor is a bit confusing for the user.

Change History (6)

comment:1 Changed 12 years ago by Martin Kou

Keywords: Confirmed IE added
Milestone: FCKeditor 2.5
Version: SVN

Confirmed in IE, does not occur in Firefox.

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.5FCKeditor 2.6

At the current stage, we are not able to work on this for the 2.5.

comment:3 Changed 11 years ago by Martin Kou

Description: modified (diff)

Tidied up the description.

comment:4 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Discussion added
Milestone: FCKeditor 2.6FCKeditor 2.6.1

This is related to the way IE position the cursor, which is currently out of our control. Of course, we could add some overhead to the editor to try to fix it, but well... it would be more overhead. We must still find out if it is really a critical thing.

comment:5 Changed 11 years ago by Martin Kou

I think we should leave it as-is, because the behavior is seen in Microsoft Word as well. Some users may actually be used to this behavior.

comment:6 Changed 11 years ago by Martin Kou

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy