Opened 6 years ago

Closed 5 years ago

#10845 closed Bug (duplicate)

Justify commands break on non-editable elements

Reported by: Piotr Jasiun Owned by: Piotr Jasiun
Priority: Normal Milestone:
Component: General Version: 4.3 Beta
Keywords: Cc:

Description (last modified by Piotrek Koszuliński)

  1. Go to Mathematics sample.
  2. Create paragraph with MathJax widget.
  3. Press Align Right button.

New paragraph is created instead of moving widget.

For better understanding of this problem, try to align right the last paragraph in MathJax sample. Widget is in the middle of it and if you place caret after the widget, the command will be applied only to the part of paragraph after widget.

Change History (5)

comment:1 Changed 6 years ago by Piotr Jasiun

Description: modified (diff)

comment:2 Changed 6 years ago by Piotrek Koszuliński

Description: modified (diff)
Status: newconfirmed
Summary: MathJax widget - justifyJustify commands break on non-editable elements

Made the ticket more generic.

comment:3 Changed 5 years ago by Piotr Jasiun

Owner: set to Piotr Jasiun
Status: confirmedassigned

comment:4 Changed 5 years ago by Piotr Jasiun

Because it may be connected with iterator issue, it should wait for #10822.

comment:5 Changed 5 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.3
Resolution: duplicate
Status: assignedclosed

Duplicates #10822 and #10991.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy