Opened 6 years ago

Last modified 4 years ago

#10847 confirmed Bug

[FF] Incorrect cursor position on Backspace

Reported by: Irina Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: IBM Cc: Teresa Monahan, Satya Minnekanti

Description

To Reproduce:

  1. Type some text and press Enter key
  2. Hit Backspace
  3. New empty paragraph removed & cursor goes back to end of the first paragraph
  4. Press spacebar or type some text

Problem: Cursor moves to next line

Attachments (1)

ff_sudden_newline.mp4 (186.7 KB) - added by Olek Nowodziński 6 years ago.
Screencast for the ticket

Download all attachments as: .zip

Change History (16)

comment:1 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 4.2.2

comment:2 Changed 6 years ago by Piotrek Koszuliński

Status: newconfirmed

I can confirm it. Regression after 4.2.

comment:3 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

Fixed by #10812.

comment:4 Changed 6 years ago by Satya Minnekanti

I could still reproduce the issue. Open Replace textarea elements by class name sample, select all the content by using Ctrl + A and press Delete or Backspace to delete the content. Repeat steps 1-4 mentioned in the description, we can reproduce the issue. Please re-open the ticket

comment:5 Changed 6 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.2.2
Resolution: fixed
Status: closedreopened
Version: 4.2.1

Unfortunately I confirm this. This TC is very fragile and somehow I repeatedly tested it incorrectly on 4.2 and 4.2.2, confirming it only on 4.2.1 :|.

The TC has to be exactly this (no focus/selection changes, or additional keystrokes):

  1. Open replacebyclass sample.
  2. Click in editor, CTRL+A, backspace (once!).
  3. Type something, enter, backspace.
  4. Type something again.

Using these steps I was able to reproduce this issue at least from CKEditor 4.0.

Changed 6 years ago by Olek Nowodziński

Attachment: ff_sudden_newline.mp4 added

Screencast for the ticket

comment:6 Changed 6 years ago by Olek Nowodziński

Status: reopenedconfirmed

comment:7 Changed 6 years ago by Jakub Ś

Version: 3.0

With TC from comment:5 I was able to reproduce this problem from CKEditor 3.0 (Perhaps this is some new browser quirks/feature.) in both CKE 3.x and 4.x.

NOTE: I believe we had similar issue once #4964. In this case, this is what gets inserted into editor when you start typing in it <p>text<br /></p>. Once you hit enter and backspace cursor most likely is inserted after BR thus the result: <p>text<br />^</p>

Last edited 6 years ago by Jakub Ś (previous) (diff)

comment:8 Changed 6 years ago by Jakub Ś

There is very similar issue: #10209. I believe they both duplicate each other and can be fixed with one patch.

comment:9 Changed 6 years ago by Piotrek Koszuliński

I wonder if #10966 and #10965 are not related too. Looks a little bit like a change in Firefox which caused all of them.

comment:10 Changed 5 years ago by Mike Gifford

I can't repeat this problem in Drupal 8 following the steps indicated in the summary.

Would I be having trouble replicating this problem as I'm using a Mac?

comment:11 Changed 4 years ago by Piotrek Koszuliński

I cannot reproduce this issue issue any more. Can you check it guys?

comment:12 Changed 4 years ago by Irina

I still see the issue by following those steps:

1.Type some word, e.g. test

2.press Enter key

3.Type some word again, e.g. test

4.Press Ctrl+Z (or undo toolbar button) to undo the last step

5.Hit Backspace so that cursor goes back to end of the first paragraph

6.Press spacebar or type some text

comment:13 Changed 4 years ago by Marek Lewandowski

Above issue and the one from the description is still reproducible with FF@Win7 and Mac. It's important to use new page button to clear the content.

If you'll use ctrl/cmd+a + backspace to clear the content then the issue is not reproducible.

Last edited 4 years ago by Marek Lewandowski (previous) (diff)

comment:14 Changed 4 years ago by Marek Lewandowski

Summary: Firefox: Incorrect cursor position on backspace[FF] Incorrect cursor position on backspace

comment:15 Changed 4 years ago by Anna Tomanek

Summary: [FF] Incorrect cursor position on backspace[FF] Incorrect cursor position on Backspace
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy