Opened 6 years ago

Closed 6 years ago

#10870 closed Bug (fixed)

Do not disable paste command when clipboard is empty

Reported by: Piotrek Koszuliński Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.3
Component: General Version: 4.3 Beta
Keywords: Cc:

Description (last modified by Piotrek Koszuliński)

Paste command accepts data as an argument. It is very useful in cases similar to pasting, like a drag&drop feature. However, we're disabling paste command if clipboard is empty what... breaks d&d and some of our tests.

Disabling paste command when clipboard is empty makes only a minor feature, because most of the time clipboard isn't empty and usually one first copies something before he tries to paste it. But the disadvantage is big - it completely breaks useful paste command and usually it also means a bugfoot, because it's very hard to understand why reported issue can't be reproduced any more.

Change History (7)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Description: modified (diff)

comment:2 Changed 6 years ago by Olek Nowodziński

cc

comment:3 Changed 6 years ago by Piotrek Koszuliński

Status: newconfirmed

comment:4 Changed 6 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:5 Changed 6 years ago by Piotrek Koszuliński

Status: assignedreview

Pushed t/10870.

comment:6 Changed 6 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

comment:7 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Fixed on major with git:74daa1f.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy