Opened 6 years ago

Closed 5 years ago

#10892 closed Bug (duplicate)

All menu auto closes

Reported by: Himanshu Negi Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0
Keywords: IE Cc:

Description

Hi, Am using latest version of Ck Editor. Currently am facing problem on IE8, Rest Chrome and Firefox are working fine. I am using j query dialogue to open pop up.

The ck Editor opens up fine and working great as expected. The only problem i get is when i click on buttons that have a drop down menu like color, styles, font etc. They open up for a second and close on their own.

Please don`t confuse it with the Z Index problem as i am able to see the menu for a split sec. Also other items like link, file upload are working fine. These have their own dialogue pop up

Sorry for the bad explainnation

Attachments (1)

jquerydialog.html (2.4 KB) - added by Jakub Ś 6 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 6 years ago by Jakub Ś

Status: newpending
Version: 4.2.2 (GitHub - master)

Please provide reduced sample HTML page showing this problem.

  1. Are you using modal popup?
  2. Which version of jQuery you use?

I believe this is jQuery issue. Please have a look at two below tickets - http://dev.ckeditor.com/ticket/10269
http://dev.ckeditor.com/ticket/10081#comment:5
Does using older version or workarounds solve your problem?

comment:2 Changed 6 years ago by Himanshu Negi

Sorry for the delay. Was on week end.

1)Yes we are using Modal Pop up 2)We are currently using 'jquery-1.9.1.js' and 'jquery-ui-1.10.2.min.js'

Facing this issue on IE8. Working fine on firefox and chrome

Will have a look at the links and update.

comment:3 Changed 6 years ago by Himanshu Negi

YES it was Jquery UI problem. I switched back to 1.9.2 and everyting seems working fine ! Thanks for the help guys !

comment:4 Changed 6 years ago by Jakub Ś

Keywords: IE added
Status: pendingconfirmed
Version: 4.0

Please have a look at http://dev.ckeditor.com/ticket/10269#comment:14. It leads to http://bugs.jqueryui.com/ticket/9087#comment:30 which contains fix for both issues. All this makes this ticket a duplicate of #10269.

Last edited 5 years ago by Jakub Ś (previous) (diff)

Changed 6 years ago by Jakub Ś

Attachment: jquerydialog.html added

comment:5 Changed 5 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy