Opened 6 years ago

Closed 6 years ago

#10893 closed Bug (fixed)

IndexSizeError is thrown on undo

Reported by: Jakub Ś Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0
Keywords: IE Firefox Cc:

Description (last modified by Jakub Ś)

Problem can be reproduced in Firefox and IE9-10. To reproduce:

  1. Open the “Replace textarea elements by class name” sample page.
  2. Put the cursor in the editor content.
  3. Control-A to select all text and then DELETE.
  4. Paste in some unformatted text 3 times (I typed "this pasted in" in notepad and copied it to the clipboard).
  5. Enter carriage return.
  6. Paste the text in 3 more times.
  7. Click undo two times.

Problem can be reproduced in Firefox from CKEditro 4.0 beta with BR_mode only.

Problem can be best reproduced in IE when BR mode is used but this isn't necessary. In IE this is issue can be reproduced from CKE 4.0.

JS error is thrown: Message: IndexSizeError: Index or size is negative or greater than the allowed amount
Line: 1942
URI: ckeditor4/core/selection.js
Code: nativeRange.setStart( range.startContainer.$, range.startOffset );

Change History (6)

comment:1 Changed 6 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 6 years ago by Jakub Ś

Other issues where IndexSizeError is mentioned: #10869, #10858, #10411, #10972.

Last edited 6 years ago by Jakub Ś (previous) (diff)

comment:3 Changed 6 years ago by Piotrek Koszuliński

Perhaps part of #10812.

comment:4 Changed 6 years ago by Jakub Ś

Description: modified (diff)
Summary: IndexSizeError is thrown on undo when Enter_BR is usedIndexSizeError is thrown on undo
Version: 4.2.14.0

comment:5 Changed 6 years ago by Jakub Ś

NOTE: I wasn't able to reproduce this on latest master.

comment:6 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

This issue was fixed in 4.2.1. Most likely I was right that it was a caused by #10812.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy