Opened 6 years ago

Closed 5 years ago

#10900 closed Bug (duplicate)

SCRIPT5007: Unable to get value of the property 'getSelection': object is null or undefined

Reported by: Eric Belair Owned by:
Priority: Normal Milestone:
Component: UI : Toolbar Version:
Keywords: Cc:

Description

I am getting the above error randomly when clicking in the text area and/or typing in the text area.

Console in IE9 states that it is occurring on line 348 character 18, which brings me to:

f=e.defaultView.getSelection()

I am including the necessary files:

        <script src="/spellchecker/spell.js" type="text/javascript"></script>
        <script
            type="text/javascript"
            src="/assets/js/ckeditor_4.1.2/ckeditor.js"></script>

Here is my initialization script:

                CKEDITOR.replace('message', {
                    customConfig: '/assets/js/ckeditor_4.1.2/custom/config.js',
                    extraPlugins : 'foundeospellchecker'
                });

Change History (2)

comment:1 Changed 5 years ago by Jakub Ś

Status: newpending
Version: 4.1.2
  1. Have you tried reproducing this issue without third-party spellchecker?
  2. What is that plugin. I have found this page but it says that plugin hasn't been published yet and it has no compatibility table.
  3. What is defined in you custom config file? Please try checking if any of options mentioned there causes this problem.

comment:2 Changed 5 years ago by Eric Belair

Component: GeneralUI : Toolbar
Resolution: duplicate
Status: pendingclosed

Yes, this issue has been reproduced without the spellchecker plug-in. This is now a duplicate of bug #10910. See that ticket for more info. http://dev.ckeditor.com/ticket/10910

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy