Opened 6 years ago

Closed 6 years ago

#10912 closed Bug (fixed)

Links with children elements are not handled correctly in a readonly block

Reported by: xmo Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.2.2
Component: Core : Editable Version:
Keywords: Cc:

Description

This is essentially a subset of #6032 which wasn't fixed then.

Do the same thing as in #6032 but put a child element in the link, e.g. an image:

  • load an editor with the html
    <p contenteditable="false">
        <a href="http://ckeditor.com">
            <img src="http://b.cksource.com/a/1/10th/ckeditor10years.png">
        </a>
    </p>
    
  • click on the image

Expected: nothing happens (link disabled) Observed: the ckeditor main page opens

Attachments (2)

10912.patch (569 bytes) - added by xmo 6 years ago.
10912.html (895 bytes) - added by Piotrek Koszuliński 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by xmo

Attachment: 10912.patch added

comment:1 Changed 6 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.2.2
Status: newconfirmed

Thanks for the patch. We'll check it for 4.2.2, to have it ready in 4.3 in which we are beginning to heavily use non-editable content.

comment:2 Changed 6 years ago by Jakub Ś

Since this is continuation, problem can be reproduced in all browsers from CKEditor 3.4 in CKE 3.x and 4.x.

comment:3 Changed 6 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

Changed 6 years ago by Piotrek Koszuliński

Attachment: 10912.html added

comment:4 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: assignedclosed

Fixed on master with git:6b9293d. Thanks for the patch :).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy