Opened 9 years ago

Closed 9 years ago

#6032 closed Bug (fixed)

Links are not handled correctly in a readonly block

Reported by: Sa'ar Zac Elias Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.4
Component: General Version: SVN (CKEditor) - OLD
Keywords: Cc:

Description

First TC

  • Open a sample, go to source and paste the following:
    <p contenteditable="false"><a href="http://ckeditor.com">Link in a readonly block</a></p>
    
  • Go to wysiwyg mode.

Notice that the CKEditor main page opens in the editing window.

Second TC

  • Load an editor with the following html:
    <p contenteditable="false"><a href="http://ckeditor.com">Link in a readonly block</a></p>
    
  • Click on the link.

Notice that the CKEditor main page opens in the editing window.

Attachments (1)

6032.patch (662 bytes) - added by Frederico Caldeira Knabben 9 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 9 years ago by Sa'ar Zac Elias

Third TC

  • Load an editor with the following html:
    <p contenteditable="false"><a href="http://ckeditor.com">Link in a readonly block</a></p>
    
  • Right click on the link.

Notice that a new paragraph is created above and the parent container is not selected.

comment:2 Changed 9 years ago by Charlie

This also occurs on FF 3.6.7

comment:3 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: IE removed
Status: newconfirmed
Summary: [IE] Links are not handled correctly in a readonly blockLinks are not handled correctly in a readonly block

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Owner: set to Frederico Caldeira Knabben
Status: confirmedassigned

Too many issues on a single ticket. We should have separated tickets for then, at least for the "Third TC".

Anyway:

  • First TC: I was not able to reproduce it. Isn't the "click" step missing there, making it a DUP of the second TC?
  • Third TC: It's not related to the issue related in the ticket. Deserves a dedicated one.

Changed 9 years ago by Frederico Caldeira Knabben

Attachment: 6032.patch added

comment:5 Changed 9 years ago by Frederico Caldeira Knabben

Status: assignedreview

comment:6 Changed 9 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

The first TC only happens in IE.
Filed #6036 for the third TC
The patch fixes the second issue, so R+ for now.

comment:7 Changed 9 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: review_passedclosed

Fixed with [5751].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy